summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreolianoe2016-06-13 13:10:21 +0200
committereolianoe2016-06-13 13:10:21 +0200
commit4bfd1ad0748d214ae7f7e961183c6ef435352cd3 (patch)
treefbe13be35c8d78b185936e90ec81d3b71a271cc6 /PKGBUILD
parent894b3b2e4b296b1e1c8227ffcde88e9d1b14594a (diff)
downloadaur-4bfd1ad0748d214ae7f7e961183c6ef435352cd3.tar.gz
Fix to work with hdf5-openmpi
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 24 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4864bfa555d5..f52c4e22cb33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=silo
pkgver=4.10.2
-pkgrel=4
+pkgrel=5
pkgdesc="A Mesh and Field I/O Library and Scientific Database"
url="https://wci.llnl.gov/simulation/computer-codes/silo"
arch=('i686' 'x86_64')
@@ -14,10 +14,12 @@ makedepends=('gcc-fortran')
license=('BSD' 'custom')
source=("https://wci.llnl.gov/content/assets/docs/simulation/computer-codes/${pkgname}/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz"
"${pkgname}-${pkgver}-rocket-test.patch"
- "${pkgname}-${pkgver}-skip-test.patch")
+ "${pkgname}-${pkgver}-skip-test.patch"
+ "${pkgname}-${pkgver}-remove-mpiposix.patch")
sha256sums=('3af87e5f0608a69849c00eb7c73b11f8422fa36903dd14610584506e7f68e638'
'd66a7a47c4dbb3be20fe3d35275a38de7e23c7b6d7927627255f7a5d49aefb47'
- '414b39df3d60bd897ea7f19c28314e8c9fae56106a0962d9116fc65aef9aba2f')
+ '414b39df3d60bd897ea7f19c28314e8c9fae56106a0962d9116fc65aef9aba2f'
+ '64a3c49eb6032dbd2bd0bbbe8110dea77d1d8a99379d96eca15c6b7c0a6f658e')
_install_docs=1
@@ -28,43 +30,31 @@ prepare(){
# Disable szip test as extra/hdf5 is not linked to szip,
# also disable test 46 (write object from python module)
patch tests/testsuite.at < "${srcdir}/${pkgname}-${pkgver}-skip-test.patch"
+
+ # Patch to use extra/hdf5-openmpi, from
+ # https://sources.debian.net/src/silo-llnl/4.10.2-5/debian/patches/remove-mpiposix.patch/
+ patch src/hdf5_drv/silo_hdf5.c < "${srcdir}/${pkgname}-${pkgver}-remove-mpiposix.patch"
+
}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
export PYTHON=/usr/bin/python2
- if [ "$(pacman -Qs hdf- | grep -o mpi)" == "mpi" ]
- then
- ./configure \
- --prefix=/usr \
- --enable-shared --enable-optimization \
- --enable-fortran --enable-browser \
- --enable-silex \
- --with-Qt-dir= --with-Qt-include-dir=/usr/include/qt4 \
- --with-Qt-bin-dir=/usr/lib/qt4/bin --with-Qt-lib-dir=/usr/lib \
- --with-Qt-lib="{QtCore,QtGui}" \
- --with-zlib=/usr/include,/usr/lib \
- --enable-pythonmodule \
- --with-szlib=/usr/lib \
- --enable-install-lite-headers \
- --enable-hzip --enable-fpzip
- else
- ./configure \
- --prefix=/usr \
- --enable-shared --enable-optimization \
- --enable-fortran --enable-browser \
- --enable-silex \
- --with-Qt-dir= --with-Qt-include-dir=/usr/include/qt4 \
- --with-Qt-bin-dir=/usr/lib/qt4/bin --with-Qt-lib-dir=/usr/lib \
- --with-Qt-lib="{QtCore,QtGui}" \
- --with-zlib=/usr/include,/usr/lib \
- --with-hdf5=/usr/include,/usr/lib \
- --enable-pythonmodule \
- --with-szlib=/usr/lib \
- --enable-install-lite-headers \
- --enable-hzip --enable-fpzip
- fi
+ ./configure \
+ --prefix=/usr \
+ --enable-shared --enable-optimization \
+ --enable-fortran --enable-browser \
+ --enable-silex \
+ --with-Qt-dir= --with-Qt-include-dir=/usr/include/qt4 \
+ --with-Qt-bin-dir=/usr/lib/qt4/bin --with-Qt-lib-dir=/usr/lib \
+ --with-Qt-lib="{QtCore,QtGui}" \
+ --with-zlib=/usr/include,/usr/lib \
+ --with-hdf5=/usr/include,/usr/lib \
+ --enable-pythonmodule \
+ --with-szlib=/usr/lib \
+ --enable-install-lite-headers \
+ --enable-hzip --enable-fpzip
make
}