summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpappy2018-09-21 14:21:12 +0300
committerpappy2018-09-21 14:21:12 +0300
commit0141298abf2fd3f5ac8daa205a57832ec35b3307 (patch)
tree4cf12e7bcb80f0b6a22ed0d49f863190b808760a /PKGBUILD
parent4e0553f122e8cdee2e4b6bcc888c2a86a58b9ea6 (diff)
downloadaur-0141298abf2fd3f5ac8daa205a57832ec35b3307.tar.gz
fixed self-conflicting issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c6720455e048..b687e5c31cf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=simavr
pkgbase=$_pkgname-git
pkgname=($pkgbase $pkgbase-examples)
-pkgver=1.6.0.20
+pkgver=1.6.0.30
pkgrel=1
pkgdesc='A lean, mean and hackable AVR simulator'
arch=('x86_64')
@@ -14,9 +14,6 @@ makedepends=('avr-libc' 'git' 'freeglut' 'glu')
source=("$pkgbase::git+https://github.com/buserror/simavr.git")
options=(!strip)
md5sums=('SKIP')
-provides=(simavr)
-conflicts=(simavr)
-replaces=(simavr)
pkgver()
{
@@ -48,6 +45,8 @@ build() {
eval 'package_'$pkgbase'() {
cd $srcdir/$pkgbase
+ provides=($_pkgname)
+ conflicts=($_pkgname)
make PREFIX="/usr" DESTDIR="$pkgdir/usr" RELEASE=1 install
}