summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHong Shick Pak2015-07-13 01:56:16 -0700
committerHong Shick Pak2015-07-13 01:56:29 -0700
commitb5729964b4a7805c512928622d60475109745f43 (patch)
tree615441cb3a0da8bb0d0514b1e75ffbd0bcc229fa /PKGBUILD
downloadaur-b5729964b4a7805c512928622d60475109745f43.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e00ba473e40b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Hong Shick Pak <hong@hspak.com>
+
+pkgname=simpfand-git
+pkgver=v4.2.9.gaa475fc
+pkgrel=1
+pkgdesc="A simple fan control daemon for ThinkPads"
+arch=('i686' 'x86_64')
+url="http://github.com/hspak/simpfand"
+license=('MIT')
+depends=()
+makedepends=('git')
+conflicts=('simpfand')
+provides=('simpfand')
+source=("git://github.com/hspak/simpfand")
+install=simpfand-git.install
+md5sums=('SKIP')
+
+pkgver() {
+ cd 'simpfand'
+ git describe | sed 's/-/./g'
+}
+
+build() {
+ make -C simpfand
+}
+
+package() {
+ make -C simpfand PREFIX=/usr DESTDIR="$pkgdir" install
+ install -D -m644 "${srcdir}/simpfand/simpfand.service" "${pkgdir}/usr/lib/systemd/system/simpfand.service"
+ install -D -m755 "${srcdir}/simpfand/restart-simpfand.sh" "${pkgdir}/usr/lib/systemd/system-sleep/restart-simpfand.sh"
+
+ # license
+ install -D -m644 "${srcdir}/simpfand/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ft=sh syn=sh et