summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGötz Christ2015-08-23 14:03:24 -0500
committerGötz Christ2015-08-23 14:03:24 -0500
commitaf3e37c67d696d9c532f930840102373b9f0fa60 (patch)
tree2c2f3e437bbf5acfe0f530907d74da798df0eb2a /PKGBUILD
downloadaur-af3e37c67d696d9c532f930840102373b9f0fa60.tar.gz
Import to AUR4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..905f7ea990ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Dan Liew <dan at su-root dot co dot uk>
+pkgname=simple-mtpfs
+pkgver=0.2
+pkgrel=1
+pkgdesc="A FUSE filesystem that supports reading/writing from MTP devices"
+arch=('i686' 'x86_64')
+url="https://github.com/phatina/simple-mtpfs/"
+license=('GPL2')
+depends=('libmtp' 'fuse' 'gcc-libs')
+options=(strip)
+source=(https://github.com/phatina/simple-mtpfs/archive/$pkgname-$pkgver.tar.gz)
+md5sums=('7dd93d869b26ebf3b630cd7c0bdd8e32')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgname-$pkgver"
+ if [[ ! -e "./configure" ]]; then
+ ./autogen.sh
+ ./configure --prefix=/usr
+ else
+ ./config.status
+ fi
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}