summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorm8D22019-09-12 15:12:15 -0700
committerm8D22019-09-12 15:12:15 -0700
commite3a3bbc43d453df62f3548e4b93754b32ab8403a (patch)
tree590ecc4591df26ae40ba283a91a46a441c9b20e9 /PKGBUILD
parent39138c443ab71e6c6a18170efcfc5aee4650de10 (diff)
downloadaur-simple-obfs-git.tar.gz
0.0.5.r46.g486bebd
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 18 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90b0d101aaef..8bf6811516b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,42 @@
+# Maintainer: m8D2 <omui (at) proton mail (dot) com>
# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: jiangxq <jiangxueqian at gmail dot com>
# Contributor: zh99998 <zh99998@gmail.com>
# Contributor: 4679kun <admin at 4679 dot us>
pkgname=simple-obfs-git
-pkgver=v0.0.5.r41.g6261a92
+pkgver=0.0.5.r46.g486bebd
pkgrel=1
pkgdesc='A simple obfusacting tool designed as plugin server of shadowsocks (git version)'
-arch=('x86_64')
+arch=(x86_64)
url='https://github.com/shadowsocks/simple-obfs'
-license=('GPL')
-depends=('libev' 'libcork')
-makedepends=('asciidoc' 'xmlto')
-conflicts=('simple-obfs')
+license=(GPL)
+depends=(libev libcork)
+makedepends=(asciidoc xmlto)
+conflicts=(simple-obfs)
source=("$pkgname::git+https://github.com/shadowsocks/simple-obfs.git")
sha512sums=('SKIP')
pkgver() {
- cd "$pkgname"
- # cutting off 'foo-' prefix that presents in the git tag
- git describe --long --tags | sed 's/^foo-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd $pkgname
+ # cutting off 'v' prefix that presents in the git tag
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd $pkgname
- patch -p1 -i debian/patches/0001-Use-libcork-dev-in-system.patch
+ cd $pkgname
+ patch -p1 -i debian/patches/0001-Use-libcork-dev-in-system.patch
}
build() {
- cd $pkgname
- ./autogen.sh
- ./configure --prefix=/usr
- make
+ cd $pkgname
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
}
package() {
- cd $pkgname
- make DESTDIR="$pkgdir" install
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
}