summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHexchain Tong2017-01-09 16:19:28 +0800
committerHexchain Tong2017-01-09 16:19:28 +0800
commit21372f3424b78a8f47814effe423a1c79170c879 (patch)
tree0eb52fbec9ab723887a24ed7dd679903a4ed949a /PKGBUILD
downloadaur-21372f3424b78a8f47814effe423a1c79170c879.tar.gz
addpkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c88fd610c028
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: hexchain <i at hexchain dot org>
+
+_pkgname="simple-obfs"
+pkgname="simple-obfs-git"
+pkgdesc="A simple obfusacting tool, designed as plugin server of shadowsocks."
+pkgver=r9.4461e1f
+pkgrel=1
+arch=(x86_64)
+license=("GPL3")
+url="https://github.com/shadowsocks/simple-obfs"
+source=("git+https://github.com/shadowsocks/simple-obfs.git")
+depends=('libsodium' 'libev' 'udns')
+
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ ./autogen.sh
+ ./configure --prefix=/usr --enable-shared --enable-system-shared-lib
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}
+sha256sums=('SKIP')