summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBadWolfie2015-06-08 13:17:19 -0500
committerBadWolfie2015-06-08 13:17:19 -0500
commit7481dc3ee44ad2ab0fcf7a4cda746776c2aa91dc (patch)
tree4de72976e5116a1875037266e515a06743c2b6dc /PKGBUILD
downloadaur-7481dc3ee44ad2ab0fcf7a4cda746776c2aa91dc.tar.gz
Migrating to AUR 4, initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d83212302e79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id$
+# Maintainer: Ian Hernandez <ihernandezs@openmailbox.org>
+
+pkgname=simple-text
+pkgver=0.9.8
+pkgrel=5
+pkgdesc="A not so simple text and code editor written in Vala (Still in development)"
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="https://github.com/BadWolfie"
+depends=('gtk3' 'gtksourceview3' 'libgee' 'vte3' 'libcap' 'dconf')
+makedepends=('vala' 'git' 'intltool')
+options=('!emptydirs')
+source=("$pkgname-$pkgver::git+$url/$pkgname.git")
+md5sums=('SKIP')
+install=$pkgname.install
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --disable-schemas-compile --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}