summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAli Neishabouri2015-06-22 19:13:13 +0100
committerAli Neishabouri2015-06-22 19:13:13 +0100
commit63315972d1e0855ef57fe7d4c2568f428db0c016 (patch)
tree8080acdc3e0010c4e714b967d62bbd9ef16497b1 /PKGBUILD
downloadaur-simple-tpm-pk11-git.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f5234aee56b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Sabart Otto - Seberm <seberm[at]gmail[dot].com
+# Contributor: Uzsolt
+
+pkgname=simple-tpm-pk11-git
+_gitname=simple-tpm-pk11
+
+pkgver=0.02.2.g7bf168f
+pkgrel=1
+pkgdesc="Simple PKCS11 provider for TPM chips. GIT version."
+url="http://blog.habets.se/2013/11/TPM-chip-protecting-SSH-keys---properly"
+arch=('any')
+license=('APACHE')
+depends=('tpm-tools' 'opencryptoki')
+optdepends=()
+conflicts=()
+provides=('simple-tpm-pk11')
+makedepends=('git')
+source=("git+https://github.com/ThomasHabets/simple-tpm-pk11.git")
+
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd ${_gitname}
+ git describe --tags | sed -E 's/\([\^\-\]\*-g\)/r/;s/-/./g;s/simple\.tpm\.pk11.//g'
+}
+
+prepare() {
+ cd ${_gitname}
+ ./bootstrap.sh
+}
+
+build() {
+ cd ${_gitname}
+ ./configure -prefix=/usr
+ make
+}
+
+package() {
+ cd ${_gitname}
+ make DESTDIR=${pkgdir} install
+}
+
+