summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDeimos2018-08-29 17:12:57 -0400
committerDeimos2018-08-29 17:12:57 -0400
commit1c3c02686115d981f509c2835488354a02d8e8b9 (patch)
treee191e237f4281bddee322971402e2e50e9edb027 /PKGBUILD
downloadaur-1c3c02686115d981f509c2835488354a02d8e8b9.tar.gz
Stage for AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4251263dee71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
+_pkgname=SimpleAgenda
+pkgname=simpleagenda.app
+pkgrel=1
+pkgver=0.44
+pkgdesc='Simple calendar and agenda application using GNUstep'
+arch=('i686' 'x86_64' 'armv7h')
+url='http://wiki.gnustep.org/index.php/SimpleAgenda.app'
+license=('BSD')
+groups=('gnustep-apps')
+depends=('gnustep-base' 'gnustep-gui' 'gnustep-back')
+makedepends=('gcc-objc' 'gnustep-make')
+optdepends=('addresses.app')
+source=("https://github.com/poroussel/simpleagenda/archive/v0.44.tar.gz")
+sha256sums=('8c23bc54861ff374277335ef36a55dea9ded0cd99cd90795edb7bdde473b9228')
+
+build() {
+ cd "simpleagenda-$pkgver"
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
+ make
+}
+
+package() {
+ cd "simpleagenda-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+}