summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjon2016-12-10 00:01:06 -0500
committerjon2016-12-10 00:10:48 -0500
commit73a63cb4b9b1ae117701cfd9f435702964886941 (patch)
treec790bad13586016b7c07109f5a798175320b99bd /PKGBUILD
parent8b62ef19f45afc9c53cd2352bfcb0042fc95db06 (diff)
downloadaur-73a63cb4b9b1ae117701cfd9f435702964886941.tar.gz
use absolute path to source dir; remove conflict with simplecv-git (package has apparently been removed)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4af473a8b342..955adca06736 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,24 @@ pkgname=simplecv
pkgver=1.3
pkgrel=2
pkgdesc='Framework for computer (machine) vision in Python, providing a unified, Pythonic interface to image aquisition, conversion, manipulation, and feature extraction.'
-url='http://simplecv.org/'
+url='http://simplecv.org'
license=('BSD')
arch=('any')
depends=('opencv' 'python2-pillow' 'python2-pygame' 'python2-scipy')
makedepends=('python2-setuptools')
optdepends=('ipython2: for using SimpleCV with the IPython Notebook')
-conflicts=('simplecv-git')
source=("http://downloads.sourceforge.net/project/${pkgname}/${pkgver}/SimpleCV-${pkgver}.tar.gz")
sha256sums=('7a0aaf61f357a78429ff4409f75d4ac67b9924f06013245706a3ccfcff8c92b0')
build() {
- cd SimpleCV
+ cd "${srcdir}/SimpleCV"
python2 setup.py build
}
package() {
- cd SimpleCV
+ cd "${srcdir}/SimpleCV"
python2 setup.py install "--root=${pkgdir}" --optimize=1
install -D --mode=u=rw,go=r LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}