summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYen Chi Hsuan2017-05-20 23:54:15 +0800
committerYen Chi Hsuan2017-05-20 23:54:15 +0800
commit7b131714820f70f41e7e84d4747f8620d56da7df (patch)
treed4497f06493359d39bd90c80972b4c856854c551 /PKGBUILD
parent1ac42336f0b6dcfaeda6a42d16a69a2daee30215 (diff)
downloadaur-7b131714820f70f41e7e84d4747f8620d56da7df.tar.gz
Switch to clang as GCC 7 is broken
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 65f6ae4ad95c..d802813ce11b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@ _pkgname=SimpleITK
pkgname=simpleitk
pkgver=1.0.0
_pypkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A simplified layer built on top of ITK, intended to facilitate its use in rapid prototyping, education, interpreted languages."
arch=('i686' 'x86_64')
url="http://www.simpleitk.org/"
license=('Apache')
depends=('gcc-libs' 'insight-toolkit>=4.11.0')
-makedepends=('cmake' 'git' 'lua51' 'mono' 'python' 'python-pip' 'python-virtualenv' 'python-numpy' 'r' 'ruby' 'swig' 'tcl' 'tk')
+makedepends=('clang' 'cmake' 'git' 'lua51' 'mono' 'python' 'python-pip' 'python-virtualenv' 'python-numpy' 'r' 'ruby' 'swig' 'tcl' 'tk')
optdepends=(
'lua51: Lua bindings'
'mono: C# bindings'
@@ -42,6 +42,7 @@ build() {
cd "$_pkgname/build"
# TODO: Java binding is broken with swig 3.0.9 and openjdk8
+ CC=clang CXX=clang++ \
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_SKIP_RPATH:BOOL=ON \