summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSamuel Walladge2016-03-30 20:28:48 +1030
committerSamuel Walladge2016-03-30 20:28:48 +1030
commit86dfe45c7d62d82d740bcfa3f078984756a61a91 (patch)
treeb213006fe78ac6645c9a1e016eabe783b42d36d6 /PKGBUILD
downloadaur-86dfe45c7d62d82d740bcfa3f078984756a61a91.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c705677bdede
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Samuel Walladge <samuel at swalladge dot id dot au>
+# Contributor: Samuel Walladge <samuel at swalladge dot id dot au>
+
+pkgname=simplenote-electron-bin
+_pkgname=simplenote
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="The simplest way to keep notes."
+arch=('x86_64')
+url="https://github.com/Automattic/simplenote-electron"
+license=('GPL2')
+depends=('gcc-libs' 'gconf' 'alsa-lib' 'nss' 'libxtst' 'gtk2' 'libnotify')
+optdepends=()
+provides=('simplenote')
+source=("https://github.com/Automattic/simplenote-electron/releases/download/v${pkgver}/${_pkgname}-${pkgver}.deb")
+md5sums=('ef05d5fce8aab117201f48c785bc1222')
+
+package() {
+ cd ${srcdir}
+
+ # extract the data part of the deb package
+ tar xzfp data.tar.gz -C ${pkgdir}
+
+ # simlink executable to /usr/bin
+ mkdir -p ${pkgdir}/usr/bin/
+ ln -s /usr/share/${_pkgname}/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+}