summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2024-05-14 11:15:05 +0200
committerKlaus Alexander Seistrup2024-05-14 11:15:05 +0200
commit1ad5a2ab47f8444998f39c3d3fa0fdf887eb30a8 (patch)
treec289a779f17f2011b5c8815ea33f7ceb0f425d83 /PKGBUILD
parent3eebf6e143f3c127b9cb9e9834d562877ec5292e (diff)
downloadaur-1ad5a2ab47f8444998f39c3d3fa0fdf887eb30a8.tar.gz
New upstream release: v5.7.3
Release notes: * https://github.com/simplex-chat/simplex-chat/releases/tag/v5.7.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 10 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ade825729a32..d17f553ae363 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='simplex-chat-bin'
_pkgname="${pkgname%%-bin}"
epoch=1
-pkgver=5.7.2
+pkgver=5.7.3
pkgrel=1
pkgdesc='A 100% private-by-design chat platform for the command-line (pre-compiled)'
arch=('x86_64')
@@ -21,6 +21,10 @@ source=(
'logo-symbol-light.svg'
'simplex-chat.desktop'
)
+sha512sums=(
+ '54f7f7bbbbbeaecd1964213e54a3e03c23dee88bd7dcbfcd7c0d137f2507174bbd81d077e6644f92889bbcfd58850624ffc7665691795f95cf184c0a7de4b87d'
+ 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
+)
license=('AGPL-3.0-or-later') # SPDX-License-Identifier: AGPL-3.0-or-later
depends=(
'glibc'
@@ -53,19 +57,11 @@ EOF
package() {
cd "$srcdir"
- # Let's be more verbose if standard output is a TTY:
- test -t 1 && _v='v' || _v=''
-
- install "-${_v}Dm0755" "$_pkgname-$pkgver" "$pkgdir/usr/bin/$_pkgname"
- install "-${_v}Dm0644" -t "$pkgdir/usr/share/doc/$pkgname/" \
- {PRIVACY,README,CLI,SIMPLEX}.md
- install "-${_v}Dm0644" "$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
- install "-${_v}Dm0644" "$_pkgname.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/$_pkgname.svg"
+ install -vDm0755 "$_pkgname-$pkgver" "$pkgdir/usr/bin/$_pkgname"
+ install -vDm0644 -t "$pkgdir/usr/share/doc/$pkgname/" \
+ {CLI,PRIVACY,README,SIMPLEX}.md
+ install -vDm0644 "$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ install -vDm0644 "$_pkgname.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/$_pkgname.svg"
}
-sha512sums=(
- '7bb59bc678532cb0174e80223a1a7edad4f2d12e1895ad4dc3e63b8e4677273a993608287865f3e90a912e963b47f4e01527e2f7dc6370388d300f1b0297a31e'
- 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
-)
-
# eof