summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2023-12-09 15:14:39 +0100
committerKlaus Alexander Seistrup2023-12-09 15:14:39 +0100
commit6eb45aeca66dc6632a7b482890ca72772ba3a7d9 (patch)
tree9b2771edce3834346ce38875aac8b83a400e92cb /PKGBUILD
parentf064dafc4c0616fc74448fa55fd40b452c607dbd (diff)
downloadaur-6eb45aeca66dc6632a7b482890ca72772ba3a7d9.tar.gz
Increase verbosity when standard output is a TTY
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b4924307286..d9f572e97fcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname='simplex-chat-bin'
_pkgname="${pkgname%%-bin}"
epoch=1
pkgver=5.4.0
-pkgrel=3
+pkgrel=4
pkgdesc='A 100% private-by-design chat platform for the command-line (pre-compiled)'
arch=('x86_64')
_platform='ubuntu-22_04-x86-64'
@@ -55,11 +55,14 @@ EOF
package() {
cd "$srcdir" || exit 1
- install -Dm0755 "$_pkgname-$pkgver" "$pkgdir/usr/bin/$_pkgname"
- install -Dm0644 message_views.sql "$pkgdir/usr/share/doc/$_pkgname/message_views.sql"
- install -m0644 {PRIVACY,README,CLI,SIMPLEX,SQL}.md "$pkgdir/usr/share/doc/$_pkgname/"
- install -Dm0644 "$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
- install -Dm0644 "$_pkgname.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/$_pkgname.svg"
+ # Let's be more verbose if standard output is a TTY:
+ test -t 1 && _verbose='v' || _verbose=''
+
+ install "-${_verbose}Dm0755" "$_pkgname-$pkgver" "$pkgdir/usr/bin/$_pkgname"
+ install "-${_verbose}Dm0644" message_views.sql "$pkgdir/usr/share/doc/$_pkgname/message_views.sql"
+ install "-${_verbose}m0644" {PRIVACY,README,CLI,SIMPLEX,SQL}.md "$pkgdir/usr/share/doc/$_pkgname/"
+ install "-${_verbose}Dm0644" "$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ install "-${_verbose}Dm0644" "$_pkgname.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/$_pkgname.svg"
}
sha256sums=(
@@ -69,9 +72,11 @@ sha256sums=(
# 🪷 Beyond the Known — 365 Days of Exploration
#
-# 📆 25th November
+# 📆 9th December
+#
+# Just look. See what is there within you; it is within us all.
#
-# …you'll never have a question of how to see…
+# It is already right there, as plain as the nose on your face.
#
# 🔗 https://magnetic-ink.dk/users/btk