summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2022-03-31 20:51:53 +0200
committerKlaus Alexander Seistrup2022-03-31 20:51:53 +0200
commit9c99d66784e5d1a33bb144547cacce05c49df1ad (patch)
treefc5c835d64b813d1a06a29d741c53a340adab4a4 /PKGBUILD
parente4076a530ff0f8baa0510b6ed21b9734a77cf9f3 (diff)
downloadaur-9c99d66784e5d1a33bb144547cacce05c49df1ad.tar.gz
Versionize executable
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 73f58ab43372..46e6d30d1190 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
pkgname='simplex-chat-bin'
_pkgname="${pkgname%%-bin}"
pkgver=1.4.1
-pkgrel=3
+pkgrel=4
pkgdesc='A 100% private-by-design chat platform (pre-compiled)'
arch=('x86_64')
_platform='ubuntu-20_04-x86-64'
url='https://simplex.chat/'
_rawurl='https://raw.githubusercontent.com/simplex-chat/simplex-chat/stable'
source=(
- "https://github.com/$_pkgname/$_pkgname/releases/download/v$pkgver/$_pkgname-$_platform"
+ "$_pkgname-$pkgver::https://github.com/$_pkgname/$_pkgname/releases/download/v$pkgver/$_pkgname-$_platform"
"$_rawurl/PRIVACY.md"
"$_rawurl/README.md"
)
@@ -34,7 +34,7 @@ b2sums=(
package() {
cd "$srcdir" || exit 1
- install -Dm0755 "$_pkgname-$_platform" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm0755 "$_pkgname-$pkgver" "$pkgdir/usr/bin/$_pkgname"
for doc in {PRIVACY,README}.md; do
install -Dm0644 "$doc" "$pkgdir/usr/share/doc/$_pkgname/$doc"