summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2023-03-16 21:25:52 +0100
committerKlaus Alexander Seistrup2023-03-16 21:25:52 +0100
commitee2c2b50482a1a056bda2d9b83ab50df96d21ac0 (patch)
tree55dfd93021175bafe184b7aa1075328aec55f262 /PKGBUILD
parentce7c00a4ed975f944ebdeff4212b43cca0eb4805 (diff)
downloadaur-ee2c2b50482a1a056bda2d9b83ab50df96d21ac0.tar.gz
Add instructions for changing icon theme
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0faa36fe339b..fb4f25d26bd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='simplex-chat-bin'
_pkgname="${pkgname%%-bin}"
pkgver=4.5.3
-pkgrel=2
+pkgrel=3
pkgdesc='A 100% private-by-design chat platform (pre-compiled)'
arch=('x86_64')
_platform='ubuntu-20_04-x86-64'
@@ -34,11 +34,19 @@ conflicts=('simplex-chat')
build() {
case "${SIMPLEX_ICON:-light}" in
- light ) _shade='light' ;;
- dark ) _shade='dark' ;;
- * ) _shade='light' ;;
+ light ) _shade='light'; _other='dark' ;;
+ dark ) _shade='dark' ; _other='light' ;;
+ * ) _shade='light'; _other='dark' ;;
esac
+ cat <<EOF
+Will package an icon suitable for a $_shade theme.
+If this is not what you want, set the environment
+variable \$SIMPLEX_ICON to “$_other”. E.g.:
+
+ env SIMPLEX_ICON=$_other makepkg [options …]
+EOF
+
cp "logo-symbol-$_shade.svg" "$_pkgname.svg"
}