summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume BOEHM2024-01-04 15:19:52 +0100
committerGuillaume BOEHM2024-01-04 15:19:52 +0100
commitcacbc95532de08447408a3a44561b0f0761c2b60 (patch)
treeb89e3c3dfd7e54b4b7c37ed92c6d78b888fe9d87 /PKGBUILD
parent4205dbc6803e773e7ff5eae39604fbef30a4b239 (diff)
downloadaur-cacbc95532de08447408a3a44561b0f0761c2b60.tar.gz
fix: use checksum in source name to avoid redownload of identical file
on rel bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f10d7c1a5c0..6df9a0004941 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,16 +10,19 @@ url="https://simplex.chat/"
license=('AGPLv3')
depends=()
options=(!strip) # necessary otherwise the AppImage file in the package is truncated
-_filename="simplex-desktop-${arch}-${pkgver}-${pkgrel}.AppImage"
-source=(
- "${_filename}::https://github.com/simplex-chat/simplex-chat/releases/download/v${pkgver}/simplex-desktop-${arch}.AppImage"
-)
-sha512sums=('2a92627cefc63a4b04b9ca0e794b5f9fa56d69c492a0995bd39ff786885c09847bf20fb1384f03aaa12686c058a94f091237b2fb093345cea32866aa43b4086f')
+
+_appimage_sum="2a92627cefc63a4b04b9ca0e794b5f9fa56d69c492a0995bd39ff786885c09847bf20fb1384f03aaa12686c058a94f091237b2fb093345cea32866aa43b4086f"
+_filename="simplex-desktop-${arch}-${pkgver}-${_appimage_sum}.AppImage"
_squashfs_desktop_file="chat.simplex.app.desktop"
_desktop_file="/usr/share/applications/simplex-desktop.desktop"
-_appimage_name=$(echo "${_filename}"|sed -E 's/-[0-9]*.[0-9]*.[0-9]*//')
+_appimage_name=$(echo "${_filename}" | sed -E "s/-${arch}-${pkgver}-${pkgrel}//")
_install_path="/opt/appimages/${_appimage_name}"
+source=(
+ "${_filename}::https://github.com/simplex-chat/simplex-chat/releases/download/v${pkgver}/simplex-desktop-${arch}.AppImage"
+)
+sha512sums=("${_appimage_sum}")
+
package() {
chmod +x "${_filename}"