summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp Claßen2015-06-13 23:32:52 +0200
committerPhilipp Claßen2015-06-13 23:32:52 +0200
commit84ae621712e70a59f69ca0f52dc3df8de0ec4fe7 (patch)
tree8498140a420a7261eaf6f7459470cd188f8dfb87 /PKGBUILD
downloadaur-84ae621712e70a59f69ca0f52dc3df8de0ec4fe7.tar.gz
Initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f69fcf710d7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Philipp Claßen <philipp.classen@posteo.de>
+pkgname=since
+pkgver=1.1
+pkgrel=1
+pkgdesc="A stateful tail command"
+arch=('i686' 'x86_64')
+url="http://welz.org.za/projects/since"
+license=('GPL')
+
+depends=(glibc)
+makedepends=(gcc)
+source=(http://welz.org.za/projects/since/since-${pkgver}.tar.gz)
+md5sums=('7a6cfe573d0d2ec7b6f53fe9432a486b')
+sha256sums=('739b7f161f8a045c1dff184e0fc319417c5e2deb3c7339d323d4065f7a3d0f45')
+
+build() {
+ cd since-${pkgver}
+ make
+}
+
+package() {
+ cd since-${pkgver}
+
+ # workaround: prefix is hard-coded in the Makefile
+ sed --in-place "s_prefix=/usr/local__" Makefile
+ make prefix="$pkgdir/usr" install
+}