summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFederico Dossena2016-02-10 13:22:23 +0100
committerFederico Dossena2016-02-10 13:22:23 +0100
commit124d6df78144130a94ca87179464cec5bc3f063c (patch)
treea35c4f82d379475c153c0a9fb0792740b9927ca5 /PKGBUILD
downloadaur-124d6df78144130a94ca87179464cec5bc3f063c.tar.gz
Uploaded to AUR
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..7aa8651fd22a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=sine
+pkgver=latest
+pkgrel=1
+pkgdesc="Brainwave Entrainment Application"
+arch=(any)
+depends=('java-runtime')
+license=('GPL3')
+url='http://sine.adolfintel.com'
+source=(sine sine-cli sine-editor sine.desktop sine-editor.desktop sine.png editor.png preset.png preset-mime.xml http://downloads.adolfintel.com/geth.php?r=sine-pcbin)
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
+install=sine.install
+
+package() {
+ cd "$srcdir"
+ echo "$pkgdir $srcdir"
+
+ rm -f "${srcdir}/"geth.*
+ rm -f "${srcdir}/"*.txt
+ rm -f "${srcdir}/"*.md
+
+ mkdir -p "${pkgdir}/usr/share/sine/"
+ mkdir -p "${pkgdir}/usr/share/applications/"
+ mkdir -p "${pkgdir}/usr/bin/"
+
+ cp -LRf "${srcdir}/"* "${pkgdir}/usr/share/sine/"
+ mv "${pkgdir}/usr/share/sine/sine" "${pkgdir}/usr/bin/SINE"
+ mv "${pkgdir}/usr/share/sine/sine-cli" "${pkgdir}/usr/bin/SINE-CLI"
+ mv "${pkgdir}/usr/share/sine/sine-editor" "${pkgdir}/usr/bin/SINE-Editor"
+ chmod 755 "${pkgdir}/usr/bin/SINE"
+ chmod 755 "${pkgdir}/usr/bin/SINE-CLI"
+ chmod 755 "${pkgdir}/usr/bin/SINE-Editor"
+ chmod -R 755 "${pkgdir}/usr/share/sine/lib"*
+ chmod 755 "${pkgdir}/usr/share/sine/"*.jar
+ chmod -R 644 "${pkgdir}/usr/share/sine/editor_manual/"*
+ mv "${pkgdir}/usr/share/sine/"*.desktop "${pkgdir}/usr/share/applications/"
+
+
+}
+