summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLone_Wolf2023-08-16 10:37:46 +0200
committerLone_Wolf2023-08-16 10:37:46 +0200
commitbd1d24e5c0b04061d1e4d9142bf0f1d51b340b98 (patch)
tree6f5dee019e268e129cc814757888e6adf427215b /PKGBUILD
parent4326b1fb840431b4c3c8045ced0b13326e483fed (diff)
downloadaur-singularity-git.tar.gz
use version independent path for site-packages
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 84bbf0f6712c..e7ff9c0bd3b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=singularity-git
_pkgname=singularity
-pkgver=r1964.a8510bd
-pkgrel=2
+pkgver=r1980.fa07970
+pkgrel=1
pkgdesc="Strategy game - simulation of true AI, git version"
arch=('any')
url="http://emhsoft.com/singularity/index.html"
@@ -29,12 +29,13 @@ build() {
}
package() {
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
cd $_pkgname
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
# music
- cp -R "$srcdir"/singularity-music/music "$pkgdir"/usr/lib/python3.10/site-packages/singularity/music
+ cp -R "$srcdir"/singularity-music/music "$pkgdir"/$site_packages/singularity/music
# desktop file