summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoachim Desroches2020-10-27 15:49:46 +0100
committerJoachim Desroches2020-10-27 15:49:46 +0100
commit2170d66c3112f75183fc41a2f00c6bd7d8cdb297 (patch)
tree8367950fa25c65c25f5df3809b5f82323eba1abe /PKGBUILD
downloadaur-2170d66c3112f75183fc41a2f00c6bd7d8cdb297.tar.gz
Release 0.2.11
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c74cd2d7f9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Joachim Desroches <joachim.desroches@epfl.ch>
+
+pkgname=sintl
+pkgver=0.2.11
+pkgrel=1
+pkgdesc='A tool for translating HTML5 web pages.'
+arch=('any')
+url='https://kristaps.bsd.lv/sintl/'
+license=('custom')
+depends=('expat')
+source=('https://kristaps.bsd.lv/sintl/snapshots/sintl.tar.gz')
+sha512sums=('5a22cd8266568798d6f045dcce47bd0e1c0949ab8515a1a08f616435eae0042dc941a2c995d3a90d43537dbfa50eaab6845ce4faa0d85f93b4dbfebe2bb547e9')
+
+build()
+{
+ cd "$pkgname-$pkgver"
+ ./configure PREFIX="$pkgdir/usr" MANDIR="$pkgdir/usr/share/man"
+ make
+}
+
+check()
+{
+ cd "$pkgname-$pkgver"
+ make regress
+}
+
+package()
+{
+ cd "$pkgname-$pkgver"
+ make install
+ # install license file whenever it is added.
+}