summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDhruva Sambrani2022-07-12 18:45:36 +0530
committerDhruva Sambrani2022-07-12 18:45:36 +0530
commitc2c912707cd1024cec62a37431e6c25d55fd900d (patch)
tree521ac2f0ce78bfb2533f5109ee71b150c75cfaf7 /PKGBUILD
parent3f4b12b6e6ec59233b2bd058245bbb6d3fa6c173 (diff)
downloadaur-c2c912707cd1024cec62a37431e6c25d55fd900d.tar.gz
Release fixes
- Renamed source to be non-conflicting - removed conflicts sioyek-git - removed GPL3 license installation - Changed pkgdesc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0cd430f4f930..ac4a2984f128 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Dhruva Sambrani <dhruvasambrani19@gmail.com>
pkgname=sioyek-appimage
pkgver=1.4.0
-pkgrel=1
-pkgdesc="The latest stable AppImage of Sioyek - a PDF viewer designed for reading research papers and technical books"
+pkgrel=2
+pkgdesc="A PDF viewer designed for reading research papers and technical books"
arch=('x86_64')
url="https://github.com/ahrm/sioyek"
-license=('GPL3')
depends=('fuse2')
# makedepends=()
# optdepends=()
provides=('sioyek')
-conflicts=('sioyek' 'sioyek-git')
+conflicts=('sioyek')
# replaces=()
# backup=()
options=(!strip)
@@ -18,15 +17,13 @@ options=(!strip)
# changelog=
_sourcezipname='sioyek-release-linux.zip'
source=(
- ${url}/releases/download/v${pkgver}/${_sourcezipname}
- ${url}/raw/v${pkgver}/LICENSE
+ ${pkgname}-${pkgver}.zip::${url}/releases/download/v${pkgver}/${_sourcezipname}
)
# noextract=()
_filename='Sioyek-x86_64.AppImage'
_install_path='/opt/appimages/Sioyek.AppImage'
md5sums=(
c0e3d0d18cd36ebf6cb065c5fd1189cf
- SKIP
) #autofill using updpkgsums
package() {
@@ -49,8 +46,4 @@ package() {
install -Dm755 "${_filename}" "${pkgdir}/${_install_path}"
mkdir "${pkgdir}/usr/bin/" && chmod 755 "${pkgdir}/usr/bin/"
ln -s "${_install_path}" "${pkgdir}/usr/bin/sioyek"
-
- # install license file
- echo Installing LICENSE
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/sioyek-appimage/LICENSE"
}