summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2021-05-25 00:01:59 -0600
committerBrian Bidulock2021-05-25 00:01:59 -0600
commit8827a19fc5538e8d2ceaa2f03f259895f76bf500 (patch)
tree81cf7ea237c12db001bb99a36bfe18a6809b70c6 /PKGBUILD
parent8ea2f39faec453fbdaac51e9b75730302ee4b6e9 (diff)
downloadaur-8827a19fc5538e8d2ceaa2f03f259895f76bf500.tar.gz
uppkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63bcc4212b62..39f7990cc982 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
-# Maintainer: Simon Gomizelj <simongmzlj@gmail.com>
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Simon Gomizelj <simongmzlj@gmail.com>
pkgname=sipp-git
-pkgver=3.5.2.170.g776223d
+pkgver=3.6.1.r42.g9f62be0
pkgrel=1
pkgdesc="A free open source test tool and traffic generator for the SIP protocol"
arch=('i686' 'x86_64')
url="http://github.com/sipp"
license=('GPL2')
source=("git+http://github.com/sipp/sipp")
-depends=('openssl' 'libpcap' 'gsl')
-makedepends=('git')
+depends=('openssl' 'libpcap' 'gsl' 'lksctp-tools')
+makedepends=('git' 'cmake')
md5sums=('SKIP')
pkgver() {
cd "sipp"
- git describe --tags | sed 's/^v//;s/-/./g'
+ git describe --long --tags | sed -E 's/^[^0-9]*//;s/([^-]*-g)/r\1/;s/-/./g'
}
prepare() {
@@ -24,13 +25,11 @@ prepare() {
build() {
cd "sipp"
- autoreconf -vifs
- ./configure --prefix=/usr \
- --with-openssl \
- --with-pcap \
- --with-rtpstream \
- --with-gsl
-
+ cmake -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DUSE_SSL=ON \
+ -DUSE_PCAP=ON \
+ -DUSE_SCTP=ON \
+ .
make sipp
}