summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent2015-07-06 01:26:52 +0200
committerVincent2015-07-06 01:26:52 +0200
commita6cccbd7f72dd45e0614f0030fe4ceb13b59c93d (patch)
tree8ab7b8e2c4a95e34f17d07d6a53a73c1a5f44565 /PKGBUILD
downloadaur-a6cccbd7f72dd45e0614f0030fe4ceb13b59c93d.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a2921dd9de2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=siril
+pkgver=0.9.0rc1
+pkgrel=1
+pkgdesc="Siril is an astronomical image processing software for Linux. (IRIS clone)"
+arch=('i686' 'x86_64')
+license=('GPLv3')
+depends=('gtk3' 'fftw' 'cfitsio' 'gsl' 'libconfig')
+makedepends=('subversion')
+url="http://free-astro.vinvin.tf/index.php/Siril"
+optdepends=('libpng: PNG import support'
+'libjpeg: JPEG import and export support'
+'libtiff: TIFF import and export support'
+'libraw: DSLR RAW images import'
+'ffms2: films native support as image sequences'
+'opencv: rotate and resize images'
+)
+source=("http://free-astro.vinvin.tf/download/siril-0.9.0-rc1.tar.gz")
+sha1sums=('17f9dcb8912a1593455b8e3382d60a8fc288b195')
+
+build() {
+ cd "${pkgname}"
+ aclocal && autoconf && autoheader && automake --add-missing
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make DESTDIR="${pkgdir}" install
+}
+