summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Koloberdin2019-03-04 05:45:39 +0200
committerMichael Koloberdin2019-03-04 05:45:39 +0200
commit2de9e1a51faed05400db41d25c1774d50860e515 (patch)
tree511851e555718465c536fd6057f1f27c854a225c /PKGBUILD
downloadaur-2de9e1a51faed05400db41d25c1774d50860e515.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7b92b08c19c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Michael Koloberdin <koloberdin@gmail.com>
+pkgname=sjasmplus
+pkgver=20190304
+pkgrel=1
+pkgdesc="SJAsmPlus: Z80 cross-assembler"
+arch=(x86_64)
+url="https://github.com/sjasmplus/sjasmplus/wiki"
+license=(ZLIB)
+depends=(boost-libs)
+makedepends=(cmake)
+source=("https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz")
+sha512sums=('ffc035c55a2b3168e6e308b9c46cc8031d56adcb0079423322cd3b447b754c9b6a64a99a26c72f26a5008461a20b36f1402d5ee7ce5ab874c1ae8493d0440d4f')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../$pkgname-$pkgver \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd build
+ install -Dm755 sjasmplus "$pkgdir/usr/bin/sjasmplus"
+}