summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfrealgagu2020-03-06 12:19:59 -0500
committerfrealgagu2020-03-06 12:19:59 -0500
commit3fb281ddbc530587179dd3fa811d80d271e47efb (patch)
tree319a1cafb707dcdf23f97fcebedbae4a573af61c /PKGBUILD
parent5196424965a1385295c391df554abf7266bbde51 (diff)
downloadaur-3fb281ddbc530587179dd3fa811d80d271e47efb.tar.gz
Cleaning modcache after build step in order to avoid issues in next builds.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b03e876c1909..4118fe19f7d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=skaffold
pkgver=1.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="A command line tool that facilitates continuous development for Kubernetes applications"
arch=("x86_64")
url="https://github.com/GoogleContainerTools/${pkgname}"
@@ -37,6 +37,9 @@ prepare() {
build() {
cd "${srcdir}/gopath/src/github.com/GoogleContainerTools/${pkgname}"
GOPATH="${srcdir}/gopath" PATH="${PATH}:${GOPATH}/bin" VERSION="v${pkgver}" COMMIT="${_commit}" TREE_STATE="clean" make install
+
+ # To avoid issues deleting directories next time
+ GOPATH="${srcdir}" go clean --modcache
}
package() {