summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraxionl2018-07-01 11:02:51 +0800
committeraxionl2018-07-01 11:02:51 +0800
commit7e7c71ce7356270b9f0fc61fe118e0a837ab3d88 (patch)
tree20dbe36b71aad0cf448c20d00dfc99e7c92bcc77 /PKGBUILD
parentcd50224b1a828cce2b838fc56aa8d347a5a4a3d8 (diff)
downloadaur-7e7c71ce7356270b9f0fc61fe118e0a837ab3d88.tar.gz
Add package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 38 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b834bc6f949d..0c9e6fb7c7d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,50 @@
+# Maintainer: Ariel AxionL <axionl@aosc.io>
pkgname=skim-git
-pkgver=0.2.1.207
+pkgver=r376.589eda7
pkgrel=1
-pkgdesc=" Fuzzy Finder in rust!"
-arch=('x86_64' 'i686')
+pkgdesc="Fuzzy Finder in rust!"
+arch=('x86_64')
+depends=('bash')
+makedepends=('git' 'rust' 'cargo')
+optdepends=("vim: Vi Improved, a highly configurable, improved version of the vi text editor."
+ "zsh: A very advanced and programmable command interpreter (shell) for UNIX"
+ "zsh-completions: Additional completion definitions for Zsh"
+ "bash-completion: Programmable completion for the bash shell")
+conflicts=("skim")
+provides=("skim")
url="https://github.com/lotabout/skim"
license=('MIT')
-depends=('ncurses')
-makedepends=('cargo')
-optdepends=()
-provides=('skim')
-conflicts=('skim')
-source=($pkgname::git+https://github.com/lotabout/skim.git)
-sha256sums=('SKIP')
+
+source=("$pkgname::git+${url}"
+ "https://raw.githubusercontent.com/lotabout/skim/master/LICENSE")
+
+sha256sums=('SKIP'
+ '97b46715104924e7ceb1f9061c21bcc13d61322f306d6b119cd47ccbf86b22ea')
pkgver() {
- cd $pkgname
- echo $(python -c "print('$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2)'.split('-')[0])").$(git rev-list --count HEAD)
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd $pkgname
- cargo build --release
+ cd "$srcdir/$pkgname/"
+ cargo build --release
}
package() {
- cd $pkgname
- install -D -m755 "$srcdir/$pkgname/target/release/sk" "$pkgdir/usr/bin/sk"
-}
+ # License
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+
+ cd $srcdir/$pkgname
+
+ # Vim plugin
+ install -Dm644 plugin/skim.vim ${pkgdir}/usr/share/vim/vimfiles/plugin/skim.vim
+
+ # Completion and keybindings
+ install -dm755 "$pkgdir/usr/share/skim"
+ install -m644 shell/*.bash shell/*.zsh "$pkgdir/usr/share/skim"
+
+ # Binaries
+ install -Dm755 bin/sk-tmux ${pkgdir}/usr/bin/sk-tmux
+ install -Dm755 target/release/sk ${pkgdir}/usr/bin/sk
+} \ No newline at end of file