summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorquininer kel2017-01-16 13:06:50 +0800
committerquininer kel2017-01-16 13:06:50 +0800
commitcd50224b1a828cce2b838fc56aa8d347a5a4a3d8 (patch)
treeeb0417b8fa945aab7ef1245f8139506426857448 /PKGBUILD
downloadaur-cd50224b1a828cce2b838fc56aa8d347a5a4a3d8.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b834bc6f949d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=skim-git
+pkgver=0.2.1.207
+pkgrel=1
+pkgdesc=" Fuzzy Finder in rust!"
+arch=('x86_64' 'i686')
+url="https://github.com/lotabout/skim"
+license=('MIT')
+depends=('ncurses')
+makedepends=('cargo')
+optdepends=()
+provides=('skim')
+conflicts=('skim')
+source=($pkgname::git+https://github.com/lotabout/skim.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ echo $(python -c "print('$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2)'.split('-')[0])").$(git rev-list --count HEAD)
+}
+
+build() {
+ cd $pkgname
+ cargo build --release
+}
+
+package() {
+ cd $pkgname
+ install -D -m755 "$srcdir/$pkgname/target/release/sk" "$pkgdir/usr/bin/sk"
+}