summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2019-04-30 20:31:25 +0200
committerhaawda2019-04-30 20:31:25 +0200
commiteae7ef063757243a585dccbf90825bfafe2affa5 (patch)
treed1982565813ea9ef17ad9b87edd086b898edca66 /PKGBUILD
parent6c870c86875730ce6d547881ebf81e28141ec63d (diff)
downloadaur-eae7ef063757243a585dccbf90825bfafe2affa5.tar.gz
rewrite
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 614170b7f904..554c7c01546d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=skribilo-git
-pkgver=0.9.4r1010
+pkgver=0.9.4.r1010
pkgrel=1
pkgdesc="The Ultimate Document Programming Framework from git"
arch=('any')
@@ -10,30 +10,33 @@ depends=('bash')
makedepends=('git' 'guile-reader' 'ploticus')
provides=('skribilo')
conflicts=('skribilo')
-source=("git://git.sv.gnu.org/skribilo.git" makevars.diff)
+source=("git://git.sv.gnu.org/skribilo.git" makevars.diff Makefile.in.in)
md5sums=('SKIP'
- 'fdefd9d3a084f4d48f57df699fb7cdf0')
+ 'fdefd9d3a084f4d48f57df699fb7cdf0'
+ '287083fa96f70fd28c8b19aae1c97b6d')
options=("!makeflags")
pkgver() {
cd "${pkgname%-git}"
- printf "%sr%s" $(git describe --tags|tr - _|cut -c2-) $(git rev-list --count HEAD)
+ printf "%s.r%s" $(git describe --tags|tr - _|cut -c2-) $(git rev-list --count HEAD)
}
prepare() {
cd "${pkgname%-git}"/po
patch -Np0 < "$srcdir"/makevars.diff
+ cp "$srcdir"/Makefile.in.in .
cd ..
-# gettextize -f
+ touch ABOUT-NLS
+ echo > gettextize --no-changelog -f
libtoolize -c -f
aclocal -I m4
automake --add-missing
- autoconf
+ autoreconf -if
}
build() {
cd "${pkgname%-git}"
- GUILE_EFFECTIVE_VERSION=2.0 GUILE=/usr/bin/guile2.0 ./configure --prefix=/usr
+ ./configure --prefix=/usr --with-guilemoduledir=/usr/share/guile/site/2.2
make
}