summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhoton892017-09-12 20:02:59 +0200
committerPhoton892017-09-12 20:02:59 +0200
commitedcaac0ec4936270fac0cb8575d5697d55b9ff89 (patch)
tree0f3558113f3183328d94bff838d5f6b715f74bb6 /PKGBUILD
downloadaur-edcaac0ec4936270fac0cb8575d5697d55b9ff89.tar.gz
Initial commit, PKGBUILD by Jameson Pugh
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6aece3fab34c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Michael Kogan <michael dot kogan at gmx dot net>
+# Contributor: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=skypeforlinux-beta-bin
+pkgver=5.4.0.1
+pkgrel=1
+pkgdesc="Skype for Linux WebRTC Beta, the older 5.x.x series - for users who experience problems with the new 8.x.x series"
+arch=('x86_64')
+url="http://www.skype.com"
+license=('custom')
+depends=('gtk2' 'libxss' 'gconf' 'alsa-lib' 'libxtst' 'libsecret' 'nss')
+optdepends=('gnome-keyring')
+conflicts=('skypeforlinux')
+provides=('skypeforlinux')
+source=("https://repo.skype.com/deb/pool/main/s/skypeforlinux/skypeforlinux_${pkgver}_amd64.deb")
+sha256sums=('1f31c0e9379f680f2ae2b4db3789e936627459fe0677306895a7fa096c7db2c5')
+
+package() {
+ cd "${srcdir}"
+
+ tar -xJC "${pkgdir}" -f data.tar.xz
+ install -d "${pkgdir}/usr/share/licenses/skypeforlinux-bin"
+ mv "${pkgdir}/usr/share/skypeforlinux/LICENSE" "${pkgdir}/usr/share/licenses/skypeforlinux-bin/"
+ mv "${pkgdir}/usr/share/skypeforlinux/LICENSES.chromium.html" "${pkgdir}/usr/share/licenses/skypeforlinux-bin/"
+ rm -rf "${pkgdir}/opt"
+}