summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Blakeney2018-11-08 14:52:06 +1000
committerMark Blakeney2018-11-08 14:52:06 +1000
commit341a6a9710257909f5920a91f6839ac127f80d83 (patch)
tree59f8498fd3db5de70af8da54529c6eab63e15e23 /PKGBUILD
parent47307337a267a81f63ded6ec5112201c11bcb5ff (diff)
downloadaur-341a6a9710257909f5920a91f6839ac127f80d83.tar.gz
Replace all 16px tray icons with 32px
Should fix corrupted tray icons. See https://answers.microsoft.com/en-us/skype/forum/skype_linux-skype_startms-skype_installms/system-tray-icon-in-xfce/d3f162bf-0bbf-481b-90a1-f43cae9a86cc?messageId=90d7e7da-7ef2-4922-af24-a7093f4a7712.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 14 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9bf5da997385..0dfa1c001bf5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,14 @@
_pkgname=skypeforlinux
pkgname=$_pkgname-stable-bin
pkgver=8.33.0.41
-pkgrel=1
+pkgrel=2
pkgdesc="Skype for Linux - Stable/Release Version"
arch=("x86_64")
url="http://www.skype.com"
license=("custom")
depends=("gtk3" "libxss" "gconf" "alsa-lib" "libxtst" "libsecret" "nss" "glibc>=2.28-4")
optdepends=("gnome-keyring")
+makedepends=("asar")
conflicts=("$_pkgname" "$_pkgname-bin" "$_pkgname-preview-bin" "$_pkgname-beta-bin" "skype")
provides=("$_pkgname" "skype")
source=(
@@ -24,6 +25,18 @@ package() {
mv "$pkgdir/usr/share/$_pkgname/LICENSES.chromium.html" \
"$pkgdir/usr/share/licenses/$pkgname/"
rm -rf "$pkgdir/opt"
+
+ # Replace all 16px tray icons with 32px.
+ _p="/usr/share/skypeforlinux/resources"
+ cd "$pkgdir/$_p"
+ asar extract app.asar _tmp
+ cd _tmp/images/tray
+ find . -iname '*@2x.png' | while read f; do
+ mv $f ${f//@2x/}
+ done
+ cd "$pkgdir/$_p"
+ asar pack _tmp app.asar
+ rm -rf _tmp
}
# vim:set ts=2 sw=2 et: