summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Blakeney2019-08-13 07:32:58 +1000
committerMark Blakeney2019-08-13 07:33:37 +1000
commit642c867235e8d19d984eb82460cf1e2edbe9c1ec (patch)
treea13a257ca95e2be7d3e80c54ff76091d9aa0f883 /PKGBUILD
parent3ae6c23909f3ee7e4bfe9479c87e402ab7f9dd4e (diff)
downloadaur-642c867235e8d19d984eb82460cf1e2edbe9c1ec.tar.gz
Update to 8.51.0.72
Also, fix setuid permission on sudo chrome-sandbox, as I recently fixed for the preview version.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 647fb557963b..bdeb39530dfa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=skypeforlinux
pkgname=$_pkgname-stable-bin
-pkgver=8.50.0.38
+pkgver=8.51.0.72
pkgrel=1
pkgdesc="Skype for Linux - Stable/Release Version"
arch=("x86_64")
@@ -17,7 +17,7 @@ provides=("$_pkgname" "skype")
source=(
"https://repo.skype.com/deb/pool/main/s/$_pkgname/${_pkgname}_${pkgver}_amd64.deb"
)
-sha256sums=('c64e27057a91cc006476d174f101a758eb917d4146078e0218f73f4c2e530abc')
+sha256sums=('63baf62b22aa6e56d55bc303c94b2d532df82aaf9d210eef7ec03b9a639763e7')
package() {
tar -xJC "$pkgdir" -f data.tar.xz
@@ -26,6 +26,12 @@ package() {
"$pkgdir/usr/share/licenses/$pkgname/"
rm -rf "$pkgdir/opt"
+ _f="/usr/share/skypeforlinux/chrome-sandbox"
+ if [ ! -u "$pkgdir/$_f" ]; then
+ echo "Adding setuid permission on $_f"
+ chmod 4755 "$pkgdir/$_f"
+ fi
+
# Replace all 16px tray icons with 32px.
_p="/usr/share/skypeforlinux/resources"
cd "$pkgdir/$_p"