summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Blakeney2023-08-02 08:36:46 +1000
committerMark Blakeney2023-08-02 08:36:46 +1000
commit951d07b8ab86c634625ecad729bfc4ef0f58aa06 (patch)
tree4ae87943d19acdb10777271fdcc4b9eb0cdb931d /PKGBUILD
parent34fa87aff43c752fc618388e1510f8913345d904 (diff)
downloadaur-951d07b8ab86c634625ecad729bfc4ef0f58aa06.tar.gz
New checksum for same version 8.100.0.203 file
Skype devs updated the download file but kept the same version number(!) so it has a different checksum. Note I now embed the $pkgrel in the download file name to avoid integrity errors when users have cached the "previous" version file.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7b45ab89d5e7..503ed3392465 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=skypeforlinux
pkgname="$_pkgname-stable-bin"
pkgver=8.100.0.203
-pkgrel=1
+pkgrel=2
pkgdesc="Skype for Linux - Stable/Release Version"
arch=("x86_64")
url="http://www.skype.com"
@@ -17,10 +17,13 @@ conflicts=("$_pkgname" "$_pkgname-bin" "$_pkgname-preview-bin"
"$_pkgname-beta-bin" "skype")
provides=("$_pkgname" "skype")
install="$pkgname-install"
+# We embed the pkgrel in the download file name because skype devs
+# sometimes use the same version number for an update and any previously
+# cached file will otherwise fail against the new checksum.
source=(
-"https://repo.skype.com/deb/pool/main/s/$_pkgname/${_pkgname}_${pkgver}_amd64.deb"
+"${_pkgname}_${pkgver}_${pkgrel}_amd64.deb::https://repo.skype.com/deb/pool/main/s/$_pkgname/${_pkgname}_${pkgver}_amd64.deb"
)
-sha256sums=('f6349089c2650b38a66d134d9ca383b79f39c5209f98ea93a09f6f92a2e64d3f')
+sha256sums=('74dfabbc23cda0d52ffbd893ced693e30e15e6b420e5cb4cede7b50d787dbcde')
package() {
tar --no-same-owner -xC "$pkgdir" -f data.tar.gz