summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSanskritFritz2015-06-14 00:42:36 +0200
committerSanskritFritz2015-06-14 00:42:36 +0200
commit6d9c499193b5c47545ce7e234a0fcf7e6510f219 (patch)
tree44a1e7aa3712db07da25148d9deb4ecd274ae6f4 /PKGBUILD
downloadaur-6d9c499193b5c47545ce7e234a0fcf7e6510f219.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a011f48e9a0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Contributor: Jakub Luzny <limoto94@gmail.com>
+# Maintainer: SanskritFritz (gmail)
+
+pkgname=sl-git
+_gitname=sl
+pkgver=5.02.r0.g0fd8d6f
+pkgrel=1
+pkgdesc='Steam Locomotive runs across your terminal when you type "sl" as you meant to type "ls"'
+arch=('i686' 'x86_64' 'arm')
+url="http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/index_e.html"
+license=('free')
+depends=('ncurses')
+makedepends=('git')
+provides=('sl')
+conflicts=('sl')
+source=("git://github.com/mtoyoda/sl.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_gitname"
+
+ cc $CFLAGS -o sl sl.c -lcurses
+ gzip -9 -f sl.1
+}
+
+package() {
+ cd "$_gitname"
+
+ install -Dm 775 sl "$pkgdir/usr/bin/sl"
+ install -Dm 644 sl.1.gz "$pkgdir/usr/share/man/man1/sl.1.gz"
+}
+
+#category: games
+# vim:set ts=2 sw=2 et: