summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorÓscar García Amor2016-12-10 12:06:47 +0100
committerÓscar García Amor2016-12-10 12:06:47 +0100
commit8096b549d2c3deca358b529229936ba72c0ce3ee (patch)
tree60279b4d99e5e9fd89cdd401667c6fbcea4019b4 /PKGBUILD
parent9429eddc9f786d6d102ed04eddbaac34f86db4db (diff)
downloadaur-8096b549d2c3deca358b529229936ba72c0ce3ee.tar.gz
Fix hardcoded icon path in .desktop file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61780072ec22..0c16d771b4a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,24 @@
pkgname=slack-desktop
pkgver=2.3.3
-pkgrel=1
+pkgrel=2
pkgdesc="Slack Desktop (Beta) for Linux"
arch=('x86_64')
url="https://slack.com/downloads"
license=('custom')
depends=('alsa-lib' 'expat' 'gconf' 'gtk2' 'gvfs' 'hunspell' 'hunspell-en' 'libgcrypt' 'libgnome-keyring' 'libnotify' 'libxss' 'libxtst' 'xdg-utils')
optdepends=('gnome-keyring')
-source=("https://downloads.slack-edge.com/linux_releases/${pkgname}-${pkgver}-amd64.deb")
-sha256sums=('30f3aae35db492c5d9e58cdba8b9fa63f0135e7658a5ceade5eb7c6d23cb3445')
+source=("https://downloads.slack-edge.com/linux_releases/${pkgname}-${pkgver}-amd64.deb"
+ "${pkgname}.patch")
+sha256sums=('30f3aae35db492c5d9e58cdba8b9fa63f0135e7658a5ceade5eb7c6d23cb3445'
+ '26ab82ad65162cb7a3aee568ecd7d3d61fcd4b95d096a530933d3b0f7771b8c3')
package() {
bsdtar -O -xf "slack-desktop-${pkgver}"*.deb data.tar.xz | bsdtar -C "$pkgdir" -xJf -
+ # Fix hardcoded icon path in .desktop file
+ patch -d ${pkgdir} -p1 <${pkgname}.patch
+
# Permission fix
find "${pkgdir}" -type d -exec chmod 755 {} +