summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSeamus Connor2019-03-11 15:47:09 -0700
committerSeamus Connor2019-03-11 15:47:09 -0700
commitec407bc2c8322f5dafb35ca688db4c9915175600 (patch)
tree292b94039329c42dd5f249492d4d1807ae95bbde /PKGBUILD
parent328543a5afe21ba3ab08b54fb55b7d9bd13bed98 (diff)
downloadaur-ec407bc2c8322f5dafb35ca688db4c9915175600.tar.gz
Switched to github.com/laCour/slack-night-mode as the theme provider
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79fff4fc2c90..13c6af421010 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Seamus Connor
+# Maintainer: Seamus Connor
pkgname=slack-desktop-dark
pkgver=3.3.7
@@ -11,11 +11,13 @@ depends=('alsa-lib' 'gconf' 'gtk3' 'libcurl-compat' 'libsecret' 'libxss' 'libxts
optdepends=('gnome-keyring')
conflicts=('slack-desktop')
source=("https://downloads.slack-edge.com/linux_releases/${pkgname%-dark}-${pkgver}-amd64.deb"
+ "https://raw.githubusercontent.com/laCour/slack-night-mode/master/css/raw/black.css"
"darkify_slack.js"
"${pkgname}.patch")
noextract=("${pkgname%-dark}-${pkgver}-amd64.deb")
sha256sums=('17310bc323eafcef86c134c7aea9b53a82f8394aa30a886ac419f9a5a23168e0'
- 'c14c22fd39a6cca72669a8a470f8b193e96757477c515f66506bd36f62b5af10'
+ '115d799ca0f7491bfe61963803babe5cb71b551e66bed9b210f7769deffaed86'
+ '3a54ac5cfa3ec9bbe5f1f1a854311f8ec9bfff4207b84357f46a94ab003e52d7'
'c952eb32dd59beff9fc5374853b04acde4a60ed8c39934fcd0b66829455d594d')
package() {
@@ -32,7 +34,11 @@ package() {
rm -rf "${pkgdir}/usr/share/lintian"
rm -rf "${pkgdir}/usr/share/doc"
- cat darkify_slack.js >> "${pkgdir}/usr/lib/slack/resources/app.asar.unpacked/src/static/ssb-interop.js"
+ lineno=$(sed -n '/HERE/=' darkify_slack.js)
+ file="${pkgdir}/usr/lib/slack/resources/app.asar.unpacked/src/static/ssb-interop.js"
+ head -n $((lineno - 1)) darkify_slack.js >> $file
+ cat black.css >> $file
+ tail -n +$((lineno + 1)) darkify_slack.js >> $file
# Move license
install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"