summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan Cholasta2013-11-17 16:56:34 +0100
committerJan Cholasta2013-11-17 16:56:34 +0100
commit3420991ba8f0a5d57c74c0cee360ce742e6e3749 (patch)
tree7b08b6e7a51e0231acf7cb694f2ade5a069957e2 /PKGBUILD
parent6bb37169ce35ac5f0066d5480daf6c565070deb5 (diff)
downloadaur-3420991ba8f0a5d57c74c0cee360ce742e6e3749.tar.gz
Updated slade to 3.1.0_b1.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 18 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0622ef5ef523..e6390f749962 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,40 +2,41 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
pkgname=slade
-pkgver=3.0.2
-pkgrel=3
+pkgver=3.1.0_b1
+pkgrel=1
pkgdesc="SLADE3 Doom editor."
arch=('i686' 'x86_64')
url="http://slade.mancubus.net/"
license=('GPL')
-depends=('fluidsynth' 'freeimage' 'sfml1.6' 'wxgtk2.9')
-makedepends=('cmake' 'imagemagick')
-source=(http://slade.mancubus.net/files/${pkgname}_302_src.zip
- build.patch)
-md5sums=('4cce3c83292ea55044b7d385bb61a907'
- '09d9a15776a96af7b1b84512bc651033')
-
-prepare() {
- patch -p1 <"$srcdir/build.patch"
-}
+depends=('fluidsynth' 'freeimage' 'ftgl' 'libmodplug' 'sfml' 'wxgtk2.9')
+makedepends=('cmake' 'imagemagick' 'zip')
+source=(https://github.com/sirjuddington/SLADE/archive/$pkgver.tar.gz
+ slade.desktop)
+md5sums=('8d5cfeef811b5438dc41f5d1826df143'
+ '49eb1692463e2aa93ea2754a5df7a6e4')
build() {
+ cd SLADE-$pkgver
+
cmake -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-2.9 \
-DwxWidgets_wxrc_EXECUTABLE=/usr/bin/wxrc-2.9 \
- -DCMAKE_INCLUDE_PATH=/usr/include/sfml-1.6 \
- -DSFML_SYSTEM_LIBRARY_SHARED_NONDEBUG=/usr/lib/libsfml-system-1.6.so \
- -DSFML_AUDIO_LIBRARY_SHARED_NONDEBUG=/usr/lib/libsfml-audio-1.6.so \
- -DCMAKE_CXX_FLAGS="-I/usr/include/sfml-1.6 -DNDEBUG" \
+ -DCMAKE_CXX_FLAGS=-DNDEBUG \
.
make
+ pushd dist/res
+ zip -r ../slade.pk3 *
+ popd
+
convert "slade.ico[0]" slade.png
}
package() {
+ cd SLADE-$pkgver
+
install -Dm755 slade "$pkgdir/usr/bin/slade"
install -Dm644 dist/slade.pk3 "$pkgdir/usr/share/slade3/slade.pk3"
install -Dm644 slade.png "$pkgdir/usr/share/pixmaps/slade.png"
- install -Dm644 slade.desktop "$pkgdir/usr/share/applications/slade.desktop"
+ install -Dm644 "$srcdir/slade.desktop" "$pkgdir/usr/share/applications/slade.desktop"
}