summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcsculley2017-12-30 12:06:10 -0600
committercsculley2017-12-30 12:06:10 -0600
commit43c1c2d89f1091c4dee270132abe1e15668b1927 (patch)
treece27b99d21c94f3d540f4f6b21df8c49ad011efc /PKGBUILD
downloadaur-43c1c2d89f1091c4dee270132abe1e15668b1927.tar.gz
Initial 1.0 commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45052e21c2b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Christopher Sculley <cs.sculley@gmail.com>
+pkgname=sleepplan-git
+pkgver=r16.4fe2ec9
+pkgrel=1
+pkgdesc="Calculate times to wake up based on bedtimes, and vice versa."
+arch=('any')
+license=('GPL3')
+url="https://csculley.site"
+makedepends=('git')
+provides=('sleepplan')
+conflicts=('sleepplan')
+source=('sleepplan::git+https://github.com/csculley/sleepplan.git#branch=master')
+md5sums=('SKIP')
+
+pkgver() {
+ mv sleepplan "$pkgname"
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$pkgname"
+ mkdir -p $pkgdir/usr/bin
+ mv sleepplan.py sleepplan
+ chmod +x sleepplan
+ cp sleepplan $pkgdir/usr/bin
+}