summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Stenglein2021-06-09 08:54:57 -0400
committerMark Stenglein2021-06-09 08:54:57 -0400
commit282dc3451aa7aab6d3e3c6c07f16202920353dd6 (patch)
treeebcfcbe67745fb280fc8a8b11ffb198f895cc0cd /PKGBUILD
parentd64adaadb5359f47e09d749bddbe9c80675b7e22 (diff)
downloadaur-282dc3451aa7aab6d3e3c6c07f16202920353dd6.tar.gz
Bump 0.1.1.r4.gf68b802
- Add go test to check()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6e9915beee5..de50d9b99bad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Mark Stenglein <aur@markstenglein.com>
pkgname=slides-git
-pkgver=0.1.1.r3.g5d89bf2
-pkgrel=2
+pkgver=0.1.1.r4.gf68b802
+pkgrel=1
pkgdesc='Terminal based presentation tool'
arch=('x86_64')
url="https://github.com/maaslalani/${pkgname%-git}"
@@ -28,12 +28,10 @@ build() {
go build -buildmode=pie -trimpath -ldflags "-linkmode external -X main.Version=${pkgver} -s -w"
}
-# Can't add until a `go vet` issue is addressed.
-# https://github.com/maaslalani/slides/issues/14
-#check() {
-# cd $pkgname
-# go test ./...
-#}
+check() {
+ cd ${pkgname%-git}
+ go test ./...
+}
package() {
cd ${pkgname%-git}