summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKimiblock2023-08-20 20:50:40 +0800
committerKimiblock2023-08-20 20:50:40 +0800
commitac63785feb732e3b96c951a8002f06105b21278d (patch)
tree9f114da16bd28ed4f49dbe042ca89a358dbe7085 /PKGBUILD
downloadaur-ac63785feb732e3b96c951a8002f06105b21278d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d358c6366303
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Kimiblock Moe
+
+pkgname=sliding-sync-git
+arch=('x86_64')
+pkgver=r1448.bcbe725
+pkgrel=1
+pkgdesc="Run a sliding sync proxy. An implementation of MSC3575."
+url=https://github.com/matrix-org/sliding-sync
+license=("Apache")
+depends=("matrix-synapse")
+source=("git+https://github.com/matrix-org/sliding-sync.git")
+makedepends=("go")
+sha256sums=('SKIP')
+provides=("sliding-sync")
+
+function pkgver(){
+ cd sliding-sync
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+function build(){
+ cd "${srcdir}/sliding-sync"
+ go build ./cmd/syncv3
+}
+
+function package(){
+ cd sliding-sync
+ install -Dm 755 "${srcdir}/sliding-sync/syncv3" "${pkgdir}/usr/bin/syncv3"
+}