summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-05-04 18:12:19 +0800
committerzxp198210052023-05-04 18:12:19 +0800
commitda85fd8703ae4fa2324d70f24aac2885991c049f (patch)
treeb1841ab130aa1a28f17c77e83508814a5754269e /PKGBUILD
parent0111d33037b9869f1c45b20c18c1a55b7837c773 (diff)
downloadaur-da85fd8703ae4fa2324d70f24aac2885991c049f.tar.gz
update libffmpeg to 0.75.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 76256b116287..27d1ce3dc2a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
_pkgname=slimjet
pkgname="${_pkgname}-beta-bin"
pkgver=39.0.0.0
-pkgrel=1
-_libffmpegverurl="https://github.com/nwjs-ffmpeg-prebuilt/nwjs-ffmpeg-prebuilt/releases"
-_libffmpegver=0.73.0
+pkgrel=2
+_libffmpegverurl="https://github.com/nwjs-ffmpeg-prebuilt/nwjs-ffmpeg-prebuilt"
+_libffmpegver=0.75.1
pkgdesc="Fast, smart and powerful browser based on Blink"
arch=('x86_64')
url="https://www.slimjet.com"
@@ -17,17 +17,17 @@ conflicts=("${_pkgname}35" "${_pkgname}")
install=
options=('!emptydirs' '!strip')
source=("${pkgname%-bin}-${pkgver}_amd64.deb::${_downurl}/beta/${_pkgname}_amd64.deb"
- "libffmpeg-${_libffmpegver}.zip::${_libffmpegverurl}/download/${_libffmpegver}/${_libffmpegver}-linux-x64.zip"
- "LICENSE::${url}/en/webhelp/index.htm")
-sha256sums=('8b48b59d74f67309159a1ccd72318ea95660e106d903c9c4f77e6f7bfdd063aa'
- '8cad02e111745402d411414d8f8d15f1504bbcd884ccf050dfad252a63ad633a'
+ "libffmpeg-${_libffmpegver}.zip::${_libffmpegverurl}/releases/download/${_libffmpegver}/${_libffmpegver}-linux-x64.zip"
+ "LICENSE.html::${url}/en/webhelp/index.htm")
+sha256sums=('86b015dca3e91a71649544501722f26db83982ac311754f32b3e752c0d398961'
+ 'ce4b76a01f2a323530e4a80e96df85043231f6fec3181231bab89a8501f11790'
'2c9dac1462b349e7c077ea33cdc91ff46563b2ca0457617958772a689b4c8d43')
package() {
bsdtar -xf data.tar.xz -C "${pkgdir}"
- bsdtar -xf "${srcdir}/libffmpeg-${_libffmpegver}.zip" -C "${pkgdir}/opt/${_pkgname}/"
+ install -Dm644 "${srcdir}/libffmpeg.so" -t "${pkgdir}/opt/${_pkgname}/"
find "${pkgdir}" -type d -exec chmod 755 {} \;
- install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${srcdir}/LICENSE.html" -t "${pkgdir}/usr/share/licenses/${pkgname}"
for _icons in 16x16 22x22 24x24 32x32 48x48 64x64 128x128 256x256; do
install -Dm644 "${pkgdir}/opt/${_pkgname}/product_logo_${_icons/x*}.png" \
"${pkgdir}/usr/share/icons/hicolor/${_icons}/apps/flashpeak-slimjet.png"