summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDalton Nell2015-07-11 15:45:30 -0600
committerDalton Nell2015-07-11 15:45:30 -0600
commit9708b5e55da0833f2816ecbcfb922e7717976fbf (patch)
treed77436be7abed1a34bc85610debc790735a72b0b /PKGBUILD
downloadaur-9708b5e55da0833f2816ecbcfb922e7717976fbf.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca9eabc38e18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: naelstrof <naelstrof@gmail.com>
+pkgname=slop-git
+_realname=slop
+pkgver=v4.1.16.r0.gf6e72a9
+pkgrel=1
+conflicts=( 'slop' )
+pkgdesc="slop (Select Operation) is an application that queries for a selection from the user and prints the region to stdout."
+arch=( 'i686' 'x86_64' )
+url="https://github.com/naelstrof/$_realname"
+license=( 'GPL3' )
+depends=( 'libxext' 'libx11' 'imlib2' 'mesa' 'glew' 'libxrender' )
+makedepends=( 'make' 'cmake' )
+source=( "slop::git+https://github.com/naelstrof/slop.git" )
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_realname"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_realname"
+ cmake -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" -DCMAKE_OPENGL_SUPPORT=true ./
+ make
+}
+
+package() {
+ cd "$srcdir/$_realname"
+
+ make install
+}