summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexis Janon2020-09-20 23:45:16 +0200
committerAlexis Janon2020-09-20 23:59:16 +0200
commit9c3dc7bb4e51f351f0c17535f2bf66c5adfc2392 (patch)
tree64eb98076da1ec81a3587fd96fd825274c6d45c1 /PKGBUILD
parent443fa8541d4faa987eaf6a6a436a02876c6a0515 (diff)
downloadaur-9c3dc7bb4e51f351f0c17535f2bf66c5adfc2392.tar.gz
patch 'os.h' to allow slurm to build
Following the removal of the 'sysctl' syscall in Linux 5.5, the GNU libc has removed the sys/sysctl.h header and associated function in version 2.32 (see the release notes: https://sourceware.org/pipermail/libc-announce/2020/000029.html). The 'os.h' file includes this removed header. This commit introduces the 'sysctl.patch' file, which removes the inclusion of the the 'sys/sysctl.h' file. The software seems to build and run fine without it.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c7d6b693e6d..71bc6f850a1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,22 @@
# Contributor: Falconindy
pkgname=slurm
pkgver=0.4.3
-pkgrel=1
+pkgrel=2
pkgdesc="Monitoring traffic statistics in realtime"
url="https://github.com/mattthias/slurm/wiki"
license=("GPL")
arch=('i686' 'x86_64')
depends=('ncurses')
makedepends=('cmake')
-source=("https://github.com/mattthias/$pkgname/archive/upstream/$pkgver.tar.gz")
-md5sums=('ff39b8e1fd31274ba1bb36d4aadc1d48')
+source=("https://github.com/mattthias/$pkgname/archive/upstream/$pkgver.tar.gz"
+ "sysctl.patch")
+md5sums=('ff39b8e1fd31274ba1bb36d4aadc1d48'
+ 'b8badc91fcfcfefebf68f1e4635c6e5f')
+
+prepare() {
+ cd "$srcdir/$pkgname-upstream-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/sysctl.patch"
+}
build() {
cd "$srcdir/$pkgname-upstream-$pkgver"