summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordian Edenhofer2016-04-06 23:57:52 +0200
committerGordian Edenhofer2016-04-06 23:57:52 +0200
commit20854b5963fe5337df9a3072f8838989efa2e786 (patch)
tree24306942aa1fefce64c0b23b7d525c4d042ef6b0 /PKGBUILD
parent811b9ce77e9f7de6b74ad45a93676b1936ae4209 (diff)
downloadaur-20854b5963fe5337df9a3072f8838989efa2e786.tar.gz
Upgpkg: 15.08.10-1
Set some more configure flags to compile more libraries into the final package in the hope that users do not have to recompile after installing a new optdep. Trigger autogen.sh for an up-to-date ./configure script.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0434bb6a3aa5..0da98af94099 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Submitter: Fredrik Tegenfeldt <fredrik.tegenfeldt@unige.ch>
pkgname=slurm-llnl
-pkgver=15.08.9
+pkgver=15.08.10
pkgrel=1
pkgdesc="Simple Linux Utility for Resource Management"
arch=('i686' 'x86_64')
@@ -28,7 +28,7 @@ optdepends=("hwloc: enables the task/cgroup plugin"
makedepends=('python')
conflicts=('slurm-llnl-dev' 'slurm-llnl-git')
backup=('etc/default/slurm-llnl')
-install=${pkgname}.install
+install="${pkgname}.install"
source=("slurm-tmpfiles.conf"
"slurm-llnl-default-conf"
"slurmctld.service"
@@ -40,7 +40,7 @@ md5sums=('51e4ae2c51edf7c145d1b87bec4c344e'
'834b641efbcb45d300630f51f08a9122'
'231a6634fcf774642021377920fffe39'
'cef9d45137b9bd431dce3cbe85ef9bca'
- '509229069300075d1caec9756ab5f5bf')
+ 'e37126cbf6205ef5369ab542c4436044')
build() {
@@ -53,11 +53,19 @@ build() {
#
# Read http://slurm.schedmd.com/quickstart_admin.html for more information
+ ./autogen.sh
./configure \
- --prefix=/usr \
- --sbindir=/usr/bin \
- --sysconfdir=/etc/slurm-llnl \
- --localstatedir=/var
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc/slurm-llnl \
+ --localstatedir=/var \
+ --enable-pam \
+ --with-proctrack \
+ --with-hdf5 \
+ --with-hwloc \
+ --with-rrdtool \
+ --with-ssl \
+ --with-munge
make
}