summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordian Edenhofer2020-11-17 21:02:07 +0100
committerGordian Edenhofer2020-11-17 21:07:19 +0100
commitd521dc27cf62d8d8e604df8c33605d1b285e3f83 (patch)
tree18e76aeac312defb726337eda94cd83db94df9b2 /PKGBUILD
parent5da2a11312c8f45ad4ee5b513092a1d8ed06940e (diff)
downloadaur-d521dc27cf62d8d8e604df8c33605d1b285e3f83.tar.gz
upgpkg: slurm-llnl 20.11.0.1-1
upgpkg: slurm-llnl-git 20.11.0.1.r1.g3e495b0ad8-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67ad14449931..30f95cb7f486 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Submitter: Fredrik Tegenfeldt <fredrik.tegenfeldt@unige.ch>
pkgname=slurm-llnl
-pkgver=20.02.6.1
+pkgver=20.11.0.1
# Hyphens (-) are prohibited however they are used by the package author
# therefore it is necessary to invoke ${pkgver} like ${pkgver//./-}
# this will substitute any full stops (.) with hyphens
@@ -31,19 +31,20 @@ optdepends=("hwloc: enables the task/cgroup plugin"
"pmix: support Open MPI applications using PMIx")
makedepends=('python' 'gtk2')
backup=('etc/default/slurm-llnl')
-install="${pkgname}.install"
-source=("slurm-tmpfiles.conf"
+source=("slurm-llnl.sysusers"
+ "slurm-llnl.tmpfiles"
"slurm-llnl-default-conf"
"slurmctld.service"
"slurmd.service"
"slurmdbd.service"
"https://github.com/SchedMD/slurm/archive/slurm-${pkgver//./-}.tar.gz")
-sha512sums=('61f07699353d607ec43bab2a4fe29b4a380dab10108619e67ca2737193ab044a6e263179f7def932660acefd34c790c9d2b301cd6a49d92b8b80deeb1c7b8011'
+sha512sums=('40aa91b02d8839ee94ae106de1ea675b0a79ba533f218afc87e909b5bbd38ce1135f54716094bf9384edc51409bfaeb0b7904cb387cbcbc8ad16befdafb8a5ab'
+ '0f1c477be4a06fd6050afd7e4fd7d3524ce4dc9bec4e3f9bbfb0087660a29f76442139b659bc906029757646ac107e521a6b2ba120b5b2db49bc815f501fb581'
'f74dacaaffa35fa11a62bb9efa492bb4ef9b197748f28c15210f362382da27ec1dd88a57a48fc6807029c93c9033c82e11545ea36622c683ae7bd09970ef8710'
'a1c2478a049dc1c024d773a73f363da6c9106d9533137f919394e8213376cb9167c8fcca7b038d1c45c441a1adce4524ccb68b6dd269a1000aba11b84b5352d5'
'ae2d0275bc9e0aac15d0d1dd4913b70ed4d4032e76c9c6ffdeae345c55834219f6495429d1d1c9129779221d6d08bada1228ccdb1c671b05d4a92ed6088bf55c'
'56459e20d7f2624a8e8dd2982693b257e65df22c3609d991afdc1b2f79adaefc0586a76fd5fdd7dc2bdd39b3af0c91f38ddc4b1139081968903450bc28aca304'
- 'a18ea6a62b8fe0318c54c4727b843840bad9e8a70b193475cf567a518357ae9d5a9ba0130970f12ebc75a1d059d401297266bbd3ec0b496a57d351ee13dd514a')
+ '9a57f2610f7294ba6cd265746b874e32a7930100f30c0adf41d95b261787c441bdcacaa641f0b9785150b94fc7d6b5b7608ec618f668bffcae6f774752f17678')
build() {
@@ -98,7 +99,8 @@ package() {
install -D -m644 ../slurmctld.service "${pkgdir}/usr/lib/systemd/system/slurmctld.service"
install -D -m644 ../slurmd.service "${pkgdir}/usr/lib/systemd/system/slurmd.service"
install -D -m644 ../slurmdbd.service "${pkgdir}/usr/lib/systemd/system/slurmdbd.service"
- install -D -m644 ../slurm-tmpfiles.conf "${pkgdir}/usr/lib/tmpfiles.d/slurm-tmpfiles.conf"
+ install -D -m644 ../slurm-llnl.sysusers "${pkgdir}/usr/lib/sysusers.d/slurm-llnl.conf"
+ install -D -m644 ../slurm-llnl.tmpfiles "${pkgdir}/usr/lib/tmpfiles.d/slurm-llnl.conf"
# Create a log and a lib dir
install -d -m755 "${pkgdir}/var/log/slurm-llnl"