summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordian Edenhofer2015-12-13 15:33:20 +0100
committerGordian Edenhofer2015-12-13 15:33:20 +0100
commit2d9ea06780721347a2f130c579a16db401bc3d1e (patch)
tree1985bf872b23c1cbbdb63ffa7d1a26f8ee0063d5 /PKGBUILD
parente79b26e8b7008976883c220fe0ff2343d0412b5f (diff)
downloadaur-2d9ea06780721347a2f130c579a16db401bc3d1e.tar.gz
Indentation: Use tabs everywhere
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD114
1 files changed, 57 insertions, 57 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ea3f79d1386..35bbee814069 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,81 +14,81 @@ url="http://www.schedmd.com"
license=('GPL')
depends=('munge')
optdepends=("hwloc: enables the task/cgroup plugin"
- "lua: the lua API will be available in various plugins"
- "libmariadbclient: support for accounting"
- "postgresql-libs: support for PostgreSQL"
- "hdf5: support for acct_gather_profile/hdf5 job profiling"
- "blcr: support for the checkpoint/blcr plugin"
- "openssl: support for the crypto/openssl CryptoType plugin"
- "pam: PAM support"
- "readline: Readline support in scontrol and sacctmgr's interactive modes"
- "libibmad: support for the acct_gather_infiniband/ofed InfiniBand accounting plugin"
- "libibumad: support for the acct_gather_infiniband/ofed InfiniBand accounting plugin"
- "man2html: HTML versions of the man pages will be generated"
- "rrdtool: support for the ext_sensors/rrd plugin"
- "numactl: NUMA support in the task/affinity plugin"
- "ncurses: adds the smap command "
- "gtk2: enables the sview command, a simple graphical frontend")
+ "lua: the lua API will be available in various plugins"
+ "libmariadbclient: support for accounting"
+ "postgresql-libs: support for PostgreSQL"
+ "hdf5: support for acct_gather_profile/hdf5 job profiling"
+ "blcr: support for the checkpoint/blcr plugin"
+ "openssl: support for the crypto/openssl CryptoType plugin"
+ "pam: PAM support"
+ "readline: Readline support in scontrol and sacctmgr's interactive modes"
+ "libibmad: support for the acct_gather_infiniband/ofed InfiniBand accounting plugin"
+ "libibumad: support for the acct_gather_infiniband/ofed InfiniBand accounting plugin"
+ "man2html: HTML versions of the man pages will be generated"
+ "rrdtool: support for the ext_sensors/rrd plugin"
+ "numactl: NUMA support in the task/affinity plugin"
+ "ncurses: adds the smap command "
+ "gtk2: enables the sview command, a simple graphical frontend")
makedepends=('python')
provides=('slurm-llnl')
conflicts=('slurm-llnl' 'slurm-llnl-git')
install=${pkgname}.install
source=("slurm-tmpfiles.conf"
- "slurm-llnl-default-conf"
- "slurmctld.service"
- "slurmd.service"
- "slurmdbd.service"
- "http://www.schedmd.com/download/total/slurm-${pkgver//_/-}.tar.bz2")
+ "slurm-llnl-default-conf"
+ "slurmctld.service"
+ "slurmd.service"
+ "slurmdbd.service"
+ "http://www.schedmd.com/download/total/slurm-${pkgver//_/-}.tar.bz2")
md5sums=('51e4ae2c51edf7c145d1b87bec4c344e'
- 'cae664b8ef44d01783dade9088e25b53'
- '31899d7a4caaa7bdb8b987afae191b56'
- '72a4cddcef47bdc989d49d02ee698e55'
- 'cd89bfa37d6b3108fc17c531a27183a0'
- '5806d610e36e2283dd4769bb1df9516b')
+ 'cae664b8ef44d01783dade9088e25b53'
+ '31899d7a4caaa7bdb8b987afae191b56'
+ '72a4cddcef47bdc989d49d02ee698e55'
+ 'cd89bfa37d6b3108fc17c531a27183a0'
+ '5806d610e36e2283dd4769bb1df9516b')
build() {
- cd "${srcdir}/slurm-${pkgver//_/-}"
+ cd "${srcdir}/slurm-${pkgver//_/-}"
- # If required libraries or header files are in non-standard locations,
- # set CFLAGS and LDFLAGS environment variables accordingly.
- # Optional Slurm plugins will be built automatically when the configure script
- # detects that the required build requirements are present.
- #
- # Read http://slurm.schedmd.com/quickstart_admin.html for more information
+ # If required libraries or header files are in non-standard locations,
+ # set CFLAGS and LDFLAGS environment variables accordingly.
+ # Optional Slurm plugins will be built automatically when the configure script
+ # detects that the required build requirements are present.
+ #
+ # Read http://slurm.schedmd.com/quickstart_admin.html for more information
- ./configure \
- --prefix=/usr \
- --sbindir=/usr/bin \
- --sysconfdir=/etc/slurm-llnl \
- --localstatedir=/var
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc/slurm-llnl \
+ --localstatedir=/var
- make
+ make
}
package() {
- cd "${srcdir}/slurm-${pkgver//_/-}"
+ cd "${srcdir}/slurm-${pkgver//_/-}"
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" install
- # slurm configs and license
- install -D -m644 etc/slurm.conf.example "${pkgdir}/etc/slurm-llnl/slurm.conf.example"
- install -D -m644 etc/slurmdbd.conf.example "${pkgdir}/etc/slurm-llnl/slurmdbd.conf.example"
- install -D -m644 LICENSE.OpenSSL "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.OpenSSL"
- install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ # slurm configs and license
+ install -D -m644 etc/slurm.conf.example "${pkgdir}/etc/slurm-llnl/slurm.conf.example"
+ install -D -m644 etc/slurmdbd.conf.example "${pkgdir}/etc/slurm-llnl/slurmdbd.conf.example"
+ install -D -m644 LICENSE.OpenSSL "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.OpenSSL"
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
- install -D -m644 ../slurm-llnl-default-conf "${pkgdir}/etc/default/slurm-llnl"
+ install -D -m644 ../slurm-llnl-default-conf "${pkgdir}/etc/default/slurm-llnl"
- # init related install
- install -D -m755 etc/init.d.slurm "${pkgdir}/etc/rc.d/slurm"
- install -D -m755 etc/init.d.slurmdbd "${pkgdir}/etc/rc.d/slurmdbd"
+ # init related install
+ install -D -m755 etc/init.d.slurm "${pkgdir}/etc/rc.d/slurm"
+ install -D -m755 etc/init.d.slurmdbd "${pkgdir}/etc/rc.d/slurmdbd"
- # SystemD related install
- install -D -m644 ../slurmctld.service "${pkgdir}/usr/lib/systemd/system/slurmctld.service"
- install -D -m644 ../slurmd.service "${pkgdir}/usr/lib/systemd/system/slurmd.service"
- install -D -m644 ../slurmdbd.service "${pkgdir}/usr/lib/systemd/system/slurmdbd.service"
- install -D -m644 ../slurm-tmpfiles.conf "${pkgdir}/etc/tmpfiles.d/slurm-tmpfiles.conf"
+ # SystemD related install
+ install -D -m644 ../slurmctld.service "${pkgdir}/usr/lib/systemd/system/slurmctld.service"
+ install -D -m644 ../slurmd.service "${pkgdir}/usr/lib/systemd/system/slurmd.service"
+ install -D -m644 ../slurmdbd.service "${pkgdir}/usr/lib/systemd/system/slurmdbd.service"
+ install -D -m644 ../slurm-tmpfiles.conf "${pkgdir}/etc/tmpfiles.d/slurm-tmpfiles.conf"
- # creating a log and a lib dir
- install -d -m755 "${pkgdir}/var/log/slurm-llnl"
- install -d -m755 "${pkgdir}/var/lib/slurm-llnl"
+ # creating a log and a lib dir
+ install -d -m755 "${pkgdir}/var/log/slurm-llnl"
+ install -d -m755 "${pkgdir}/var/lib/slurm-llnl"
}