summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordian Edenhofer2016-04-18 17:39:24 +0200
committerGordian Edenhofer2016-04-18 17:39:24 +0200
commitb97151504fad1ed351c64c130ef53a02ad1017a0 (patch)
tree92ced2ee909bd1a106cf6c987ddca106a96e3b43 /PKGBUILD
parentcc42434719c39c9e6a31fd77d605ac142b9dba28 (diff)
downloadaur-b97151504fad1ed351c64c130ef53a02ad1017a0.tar.gz
Upgpkg: 16.05.0_0pre2-2
Set some more configure flags to compile more libraries into the final package in the hope that users do not have to recompile after installing a new optdep. Trigger autogen.sh for an up-to-date ./configure script. Escape possible spaces in variables.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0d744caf4c71..bab235c8ab90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgver=16.05.0_0pre2
# Hyphens (-) are prohibited however they are used by the package author
# therefore it is necessary to invoke ${pkgver} like ${pkgver//_/-}
# this will substituet any udnerscores (_) with hyphens
-pkgrel=1
+pkgrel=2
pkgdesc="Simple Linux Utility for Resource Management (development version)"
arch=('i686' 'x86_64')
url="http://www.schedmd.com"
@@ -32,7 +32,7 @@ makedepends=('python')
provides=('slurm-llnl')
conflicts=('slurm-llnl' 'slurm-llnl-git')
backup=('etc/default/slurm-llnl')
-install=${pkgname}.install
+install="${pkgname}.install"
source=("slurm-tmpfiles.conf"
"slurm-llnl-default-conf"
"slurmctld.service"
@@ -56,11 +56,19 @@ build() {
#
# Read http://slurm.schedmd.com/quickstart_admin.html for more information
+ ./autogen.sh
./configure \
- --prefix=/usr \
- --sbindir=/usr/bin \
- --sysconfdir=/etc/slurm-llnl \
- --localstatedir=/var
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc/slurm-llnl \
+ --localstatedir=/var \
+ --enable-pam \
+ --with-proctrack \
+ --with-hdf5 \
+ --with-hwloc \
+ --with-rrdtool \
+ --with-ssl \
+ --with-munge
make
}