summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHekuran2020-11-07 15:04:41 +0100
committerHekuran2020-11-07 15:04:41 +0100
commitb6173a97a69f9bb9352d2dd87b13738f3fddfec6 (patch)
treec4b720c8ede6d7bcb307fe6ba0575a4e183e312d /PKGBUILD
parentdb989c92e851e4971e31ed2ba11c0e8b60b58a7f (diff)
downloadaur-b6173a97a69f9bb9352d2dd87b13738f3fddfec6.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 908bfd398497..4aef8f5a7eba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Hekuran https://github.com/narukeh
pkgname=sm64pc-git
-pkgver=r504.f5005418
+pkgver=r513.57c20346
pkgrel=1
pkgdesc='Super Mario 64 PC (sm64ex aka. sm64pc) - OpenGL adaptation of n64decomp/sm64'
arch=('any')
url='https://github.com/sm64pc/sm64ex'
license=('reverse-engineered and unlicensed')
-depends=('python' 'audiofile' 'sdl2' 'glew')
makedepends=('git')
+depends=('python' 'audiofile' 'sdl2' 'glew')
provides=(sm64ex)
_gitname=sm64ex
_region=us
-source=('git+https://github.com/sm64pc/sm64ex.git')
+source=("git+${url}.git")
sha256sums=('SKIP')
pkgver() {
@@ -23,14 +23,14 @@ pkgver() {
}
prepare() {
- cd "$srcdir/$_gitname"
- cp "../../baserom.${_region}.z64" . || {
- printf "%$(stty size | awk '{print $2}')s\n" | sed "s/ /░/g"
- printf "\\n%s\\n%s\\n\\n" \
- "NO ROM FOUND! Copy your sm64 ROM to \"$(realpath ../../)\" and rename it to \"baserom.${_region}.z64\"." \
- "The default ROM region is US. You have to edit the PKGBUILD if you would like to use a JP or EU version."
- printf "%$(stty size | awk '{print $2}')s\n" | sed "s/ /░/g"
- }
+ cd "$srcdir/$_gitname"
+ cp "../../baserom.${_region}.z64" . || {
+ printf "%$(stty size | awk '{print $2}')s\n" | sed "s/ /░/g"
+ printf "\\n%s\\n%s\\n\\n" \
+ "NO ROM FOUND! Copy your sm64 ROM to \"$(realpath ../../)\" and rename it to \"baserom.${_region}.z64\"." \
+ "The default ROM region is US. You have to edit the PKGBUILD if you would like to use a JP or EU version."
+ printf "%$(stty size | awk '{print $2}')s\n" | sed "s/ /░/g"
+ }
}
build() {