summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVianney le Clément de Saint-Marcq2015-12-07 10:54:08 +0100
committerVianney le Clément de Saint-Marcq2015-12-07 10:54:08 +0100
commit8bfb9c5d4f225ae6579b596128676af7da59faba (patch)
treefc6b897a436d0f252fa062dc38618c7559231c6f /PKGBUILD
parent7784edca4776b7b4908015cbbc542ae3c5802211 (diff)
downloadaur-8bfb9c5d4f225ae6579b596128676af7da59faba.tar.gz
Automatically download latest beta
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cdef48c63013..5bc277f24889 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=smartscope-beta
pkgver=2015.1203.20.25
-pkgrel=1
+pkgrel=2
pkgdesc="SmartScope App (Beta version)"
arch=('x86_64' 'i686')
url="https://www.lab-nation.com/"
@@ -10,13 +10,15 @@ conflicts=('smartscope')
provides=('smartscope')
makedepends=('tar')
-_pkgver=$(echo ${pkgver} | sed 's@\.@/@g')
-
-source=("$pkgname.deb::https://www.lab-nation.com/package/smartscope/${_pkgver}/linux/get"
+source=("${pkgname}.deb::https://www.lab-nation.com/package/smartscope/linux/latest_unstable/get"
'smartscope.sh')
-md5sums=('3862a6ad8a6a280ee5a2ae485a61506b'
+md5sums=('SKIP'
'3d877cb9f75a3ef8887e1f81b69e8007')
+pkgver() {
+ tar -xzOf control.tar.gz ./control | sed -n 's/^Version: //p'
+}
+
package() {
cd "${srcdir}"
tar -xJvf data.tar.xz -C "${pkgdir}"