summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPeinthor Rene2015-06-09 13:42:15 +0200
committerPeinthor Rene2015-06-09 13:42:15 +0200
commite33c79a6ff83e7446627a3616014f996900ef49a (patch)
treed0a5348691083f2694a587896ff174cf75caf89d /PKGBUILD
downloadaur-e33c79a6ff83e7446627a3616014f996900ef49a.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..112feef01102
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+#Maintainer: Rene Peinthor <peinthor@gmail.com>
+pkgname=smartsvn
+pkgver=8.6.6
+_pkgver=8_6_6
+pkgrel=1
+pkgdesc="A Subversion(SVN) GUI client written in Java"
+arch=("any")
+url="http://www.smartsvn.com/"
+license=('custom')
+depends=("java-runtime" "desktop-file-utils" "sh")
+makedepends=()
+provides=(smartsvn=$pkgver)
+source=(smartsvn.desktop http://www.smartsvn.com/downloads/${pkgname}/${pkgname}-linux-${_pkgver}.tar.gz)
+install="smartsvn.install"
+backup=('opt/smartsvn/bin/smartsvn.sh') # might contain changes to max heap size and vmoptions
+md5sums=(
+'e3dfb3bdaef28b727b491af85498f2c0'
+'0b3dfa802949506db002d3278f0afd9b'
+)
+
+
+extracted="$pkgname-$_pkgver"
+
+build() {
+ cd "$srcdir"
+ tar xzf ${pkgname}-linux-${_pkgver}.tar.gz
+}
+
+package() {
+ cd "$srcdir"
+
+ install -D -m644 "${extracted}"/license.html "${pkgdir}/usr/share/licenses/${pkgname}/license.html"
+ mkdir -p "${pkgdir}"/opt
+ mv "${extracted}" ${pkgdir}/opt/$pkgname || return 1
+
+ install -D -m644 smartsvn.desktop "${pkgdir}"/usr/share/applications/smartsvn.desktop
+}